lkml.org 
[lkml]   [2023]   [Aug]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 1/1] drm/i915: Move abs_diff() to math.h
On Thu, Aug 03, 2023 at 10:24:46AM -0700, Andrew Morton wrote:
> On Thu, 3 Aug 2023 16:19:18 +0300 Andy Shevchenko <andriy.shevchenko@linux.intel.com> wrote:

...

> > +#define abs_diff(a, b) ({ \
> > + typeof(a) __a = (a); \
> > + typeof(b) __b = (b); \
> > + (void)(&__a == &__b); \
> > + __a > __b ? (__a - __b) : (__b - __a); \
> > +})
>
> Can we document it please?
>
> Also, the open-coded type comparison could be replaced with __typecheck()?
>
> And why the heck isn't __typecheck() in typecheck.h, to be included by
> minmax.h.
>
> etcetera. Sigh. I'll grab it, but please at least send along some
> kerneldoc?

Sure and thank you!

--
With Best Regards,
Andy Shevchenko


\
 
 \ /
  Last update: 2023-08-04 06:08    [W:0.068 / U:0.504 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site