lkml.org 
[lkml]   [2023]   [Aug]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 00/14] tty: n_tty: cleanup
From
Bah, this series intermixed with old patches in one dir.

Patches 1/4 2/4 3/4 4/4 are to be ignored.

OTOH, 01/14 ... 04/14 are a correct part of this series.

Do you want me to resend?

On 16. 08. 23, 12:58, Jiri Slaby (SUSE) wrote:
> This is another part (say part III.) of the previous type unification
> across the tty layer[1]. This time, in n_tty line discipline. Apart from
> type changes, this series contains a larger set of refactoring of the
> code. Namely, separating hairy code into single functions for better
> readability.
>
> [1] https://lore.kernel.org/all/20230810091510.13006-1-jirislaby@kernel.org/
>
> Note this is completely independent on "part II." (tty_buffer cleanup),
> so those two can be applied in any order.
>
> Jiri Slaby (SUSE) (14):
> tty: n_tty: make flow of n_tty_receive_buf_common() a bool
> tty: n_tty: use output character directly
> tty: n_tty: use 'retval' for writes' retvals
> tty: n_tty: use time_is_before_jiffies() in n_tty_receive_overrun()
> tty: n_tty: make n_tty_data::num_overrun unsigned
> tty: n_tty: use MASK() for masking out size bits
> tty: n_tty: move canon handling to a separate function
> tty: n_tty: move newline handling to a separate function
> tty: n_tty: remove unsigned char casts from character constants
> tty: n_tty: simplify chars_in_buffer()
> tty: n_tty: use u8 for chars and flags
> tty: n_tty: unify counts to size_t
> tty: n_tty: extract ECHO_OP processing to a separate function
> tty: n_tty: deduplicate copy code in n_tty_receive_buf_real_raw()
>
> drivers/tty/n_tty.c | 551 +++++++++++++++++++++++---------------------
> 1 file changed, 284 insertions(+), 267 deletions(-)
>

--
js
suse labs

\
 
 \ /
  Last update: 2023-08-16 13:05    [W:0.074 / U:0.248 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site