lkml.org 
[lkml]   [2023]   [Aug]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] net: export dev_change_name function
Tue, Aug 01, 2023 at 01:21:01PM CEST, quic_ajainp@quicinc.com wrote:
>export dev_change_name function to be used by other modules.
>
>Signed-off-by: Vagdhan Kumar <quic_vagdhank@quicinc.com>
>Signed-off-by: Anvesh Jain P <quic_ajainp@quicinc.com>
>---
> net/core/dev.c | 1 +
> 1 file changed, 1 insertion(+)
>
>diff --git a/net/core/dev.c b/net/core/dev.c
>index 69a3e544676c..1dad68e2950c 100644
>--- a/net/core/dev.c
>+++ b/net/core/dev.c
>@@ -1254,6 +1254,7 @@ int dev_change_name(struct net_device *dev, const char *newname)
>
> return err;
> }
>+EXPORT_SYMBOL(dev_change_name);
>
> /**
> * dev_set_alias - change ifalias of a device
>
>base-commit: 0a8db05b571ad5b8d5c8774a004c0424260a90bd

nack.
1) there is no in-tree user
2) changing name from anywhere else than userspace does not make any
sense. I'll eat my shoes if there is a sane reason for it.

Please don't send patches like this.


>--
>2.17.1
>

\
 
 \ /
  Last update: 2023-08-01 19:27    [W:0.377 / U:0.092 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site