lkml.org 
[lkml]   [2023]   [Jul]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH] selftests/input: add tests for the EVIOCSCLOCKID ioctl
Hi Dana,

Many thanks for the patch. Only a minor comment, see below.

Missatge de Dana Elfassy <delfassy@redhat.com> del dia dl., 3 de jul.
2023 a les 10:18:
>
> This patch introduces tests for the EVIOCSCLOCKID ioctl, for full
> coverage of the different clkids
>
> Signed-off-by: Dana Elfassy <dangel101@gmail.com>
> ---
> This patch depends on '[v3] selftests/input: Introduce basic tests for evdev ioctls' [1] sent to the ML.
> [1] https://patchwork.kernel.org/project/linux-input/patch/20230607153214.15933-1-eballetbo@kernel.org/
>
> tools/testing/selftests/input/evioc-test.c | 32 ++++++++++++++++++++++
> 1 file changed, 32 insertions(+)
>
> diff --git a/tools/testing/selftests/input/evioc-test.c b/tools/testing/selftests/input/evioc-test.c
> index ad7b93fe39cf..81d5336d93ac 100644
> --- a/tools/testing/selftests/input/evioc-test.c
> +++ b/tools/testing/selftests/input/evioc-test.c
> @@ -234,4 +234,36 @@ TEST(eviocsrep_set_repeat_settings)
> selftest_uinput_destroy(uidev);
> }
>
> +TEST(eviocsclockid_set_clockid)
> +{
> + struct selftest_uinput *uidev;
> + int clkid = 0;

instead of using "magic numbers" for all the CLOCK_* types I'd
recommend to use the defined ones in include/uapi/linux/time.h, so you
can use CLOCK_REALTIME,
CLOCK_MONOTONIC and CLOCK_BOOTTIME in the code.

> + int rc;
> +
> + rc = selftest_uinput_create_device(&uidev, -1);
> + ASSERT_EQ(0, rc);
> + ASSERT_NE(NULL, uidev);
> +
> + // case CLOCK_REALTIME
> + rc = ioctl(uidev->evdev_fd, EVIOCSCLOCKID, &clkid);
> + ASSERT_EQ(0, rc);
> +
> + // case CLOCK_MONOTONIC
> + clkid = 1;
> + rc = ioctl(uidev->evdev_fd, EVIOCSCLOCKID, &clkid);
> + ASSERT_EQ(0, rc);
> +
> + // case CLOCK_BOOTTIME
> + clkid = 7;
> + rc = ioctl(uidev->evdev_fd, EVIOCSCLOCKID, &clkid);
> + ASSERT_EQ(0, rc);
> +
> + // case default
> + clkid = -1;
> + rc = ioctl(uidev->evdev_fd, EVIOCSCLOCKID, &clkid);
> + ASSERT_EQ(-1, rc);
> +
> + selftest_uinput_destroy(uidev);
> +}
> +
> TEST_HARNESS_MAIN
> --
> 2.41.0
>

Cheers,
Enric

\
 
 \ /
  Last update: 2023-07-03 11:27    [W:0.022 / U:0.396 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site