lkml.org 
[lkml]   [2023]   [Jul]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH v3 4/8] ACPI: thermal: Clean up acpi_thermal_register_thermal_zone()
    Date
    From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>

    Rename the trips variable in acpi_thermal_register_thermal_zone() to
    trip_count so its name better reflects the purpose, rearrange white
    space in the loop over active trips for clarity and reduce code
    duplication related to calling thermal_zone_device_register() by
    using an extra local variable to store the passive delay value.

    No intentional functional impact.

    Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
    ---

    v2 -> v3: No changes.

    v1 -> v2: No changes.

    ---
    drivers/acpi/thermal.c | 36 ++++++++++++++++--------------------
    1 file changed, 16 insertions(+), 20 deletions(-)

    Index: linux-pm/drivers/acpi/thermal.c
    ===================================================================
    --- linux-pm.orig/drivers/acpi/thermal.c
    +++ linux-pm/drivers/acpi/thermal.c
    @@ -745,34 +745,30 @@ static void acpi_thermal_zone_sysfs_remo

    static int acpi_thermal_register_thermal_zone(struct acpi_thermal *tz)
    {
    - int trips = 0;
    + int passive_delay = 0;
    + int trip_count = 0;
    int result;
    acpi_status status;
    int i;

    if (tz->trips.critical.valid)
    - trips++;
    + trip_count++;

    if (tz->trips.hot.valid)
    - trips++;
    -
    - if (tz->trips.passive.valid)
    - trips++;
    -
    - for (i = 0; i < ACPI_THERMAL_MAX_ACTIVE && tz->trips.active[i].valid;
    - i++, trips++);
    -
    - if (tz->trips.passive.valid)
    - tz->thermal_zone = thermal_zone_device_register("acpitz", trips, 0, tz,
    - &acpi_thermal_zone_ops, NULL,
    - tz->trips.passive.tsp * 100,
    - tz->polling_frequency * 100);
    - else
    - tz->thermal_zone =
    - thermal_zone_device_register("acpitz", trips, 0, tz,
    - &acpi_thermal_zone_ops, NULL,
    - 0, tz->polling_frequency * 100);
    + trip_count++;

    + if (tz->trips.passive.valid) {
    + trip_count++;
    + passive_delay = tz->trips.passive.tsp * 100;
    + }
    +
    + for (i = 0; i < ACPI_THERMAL_MAX_ACTIVE && tz->trips.active[i].valid; i++)
    + trip_count++;
    +
    + tz->thermal_zone = thermal_zone_device_register("acpitz", trip_count, 0,
    + tz, &acpi_thermal_zone_ops,
    + NULL, passive_delay,
    + tz->polling_frequency * 100);
    if (IS_ERR(tz->thermal_zone))
    return -ENODEV;



    \
     
     \ /
      Last update: 2023-07-25 14:26    [W:4.064 / U:0.048 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site