lkml.org 
[lkml]   [2023]   [Jun]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Subject[PATCH 0/3] Do IRQ move cleanup with a timer instead of an IPI
    Date
    No point to waste a vector for cleaning up the leftovers of a moved
    interrupt. Aside of that this must be the lowest priority of all vectors
    which makes FRED systems utilizing vectors 0x10-0x1f more complicated
    than necessary.

    Schedule a timer instead.

    Thomas Gleixner (2):
    x86/vector: Rename send_cleanup_vector() to vector_schedule_cleanup()
    x86/vector: Replace IRQ_MOVE_CLEANUP_VECTOR with a timer callback

    Xin Li (1):
    tools: Get rid of IRQ_MOVE_CLEANUP_VECTOR from tools

    arch/x86/include/asm/hw_irq.h | 4 +-
    arch/x86/include/asm/idtentry.h | 1 -
    arch/x86/include/asm/irq_vectors.h | 7 --
    arch/x86/kernel/apic/vector.c | 109 ++++++++++++++----
    arch/x86/kernel/idt.c | 1 -
    arch/x86/platform/uv/uv_irq.c | 2 +-
    drivers/iommu/amd/iommu.c | 2 +-
    drivers/iommu/hyperv-iommu.c | 4 +-
    drivers/iommu/intel/irq_remapping.c | 2 +-
    tools/arch/x86/include/asm/irq_vectors.h | 7 --
    .../beauty/tracepoints/x86_irq_vectors.sh | 2 +-
    11 files changed, 92 insertions(+), 49 deletions(-)

    --
    2.34.1

    \
     
     \ /
      Last update: 2023-06-20 01:43    [W:4.223 / U:0.020 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site