lkml.org 
[lkml]   [2023]   [May]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v3 11/18] arm64: dts: qcom: sm8450: Add Qualcomm ramoops minidump node
From


On 3.05.2023 19:02, Mukesh Ojha wrote:
> This enable dynamic reserve memory for Qualcomm ramoops device,
> Which will used to save ramoops frontend data and this region
> gets dumped on crash via Qualcomm's minidump infrastructure.
> qcom_pstore_minidump is the associated driver for this node.
>
> Signed-off-by: Mukesh Ojha <quic_mojha@quicinc.com>
> ---
> arch/arm64/boot/dts/qcom/sm8450.dtsi | 11 +++++++++++
> 1 file changed, 11 insertions(+)
>
> diff --git a/arch/arm64/boot/dts/qcom/sm8450.dtsi b/arch/arm64/boot/dts/qcom/sm8450.dtsi
> index 595533a..92d023f 100644
> --- a/arch/arm64/boot/dts/qcom/sm8450.dtsi
> +++ b/arch/arm64/boot/dts/qcom/sm8450.dtsi
> @@ -614,6 +614,17 @@
> reg = <0x0 0xed900000 0x0 0x3b00000>;
> no-map;
> };
> +
> + qcom_ramoops_md_region:qcom_ramoops_md {
Missing space after ':'

node names should not contain underscores

minidump {

or

ramoops {

would probably be better names for this node
> + alloc-ranges = <0x0 0x00000000 0xffffffff 0xffffffff>;
> + size = <0x0 0x200000>;
> + no-map;
> + };
> + };
> +
> + qcom_ramoops_md {
Node names should be generic (e.g. ramdump or something) and should
not contain underscores.

Konrad
> + compatible = "qcom,sm8450-ramoops-minidump", "qcom,ramoops-minidump";
> + memory-region = <&qcom_ramoops_md_region>;
> };
>
> smp2p-adsp {

\
 
 \ /
  Last update: 2023-05-04 09:14    [W:0.368 / U:0.040 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site