lkml.org 
[lkml]   [2023]   [May]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] soc: qcom: Rename ice to qcom-ice to avoid module name conflict
On Wed, May 10, 2023 at 10:44:04AM +0300, Abel Vesa wrote:
> The following error was reported when building x86_64 allmodconfig:
>
> error: the following would cause module name conflict:
> drivers/soc/qcom/ice.ko
> drivers/net/ethernet/intel/ice/ice.ko
>
> Seems the 'ice' module name is already used by some Intel ethernet
> driver, so lets rename the Qualcomm Inline Crypto Engine (ICE) from
> 'ice' to 'qcom-ice' to avoid any kind of errors/confusions.
>
> Reported-by: Stephen Rothwell <sfr@canb.auug.org.au>
> Fixes: 2afbf43a4aec ("soc: qcom: Make the Qualcomm UFS/SDCC ICE a dedicated driver")
> Signed-off-by: Abel Vesa <abel.vesa@linaro.org>
> ---
>
> The build failure was reported here:
> https://lore.kernel.org/all/20230510111833.17810885@canb.auug.org.au/
>
> drivers/soc/qcom/Makefile | 2 +-
> drivers/soc/qcom/{ice.c => qcom-ice.c} | 0
> 2 files changed, 1 insertion(+), 1 deletion(-)
> rename drivers/soc/qcom/{ice.c => qcom-ice.c} (100%)
>

You can just rename the module name to "qcom-ice" and still keep the driver name
as "ice" as it is already under "qcom" subdirectory.

We do it for other drivers as well.

- Mani

> diff --git a/drivers/soc/qcom/Makefile b/drivers/soc/qcom/Makefile
> index 0f43a88b4894..30219c164cb0 100644
> --- a/drivers/soc/qcom/Makefile
> +++ b/drivers/soc/qcom/Makefile
> @@ -32,4 +32,4 @@ obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
> obj-$(CONFIG_QCOM_RPMPD) += rpmpd.o
> obj-$(CONFIG_QCOM_KRYO_L2_ACCESSORS) += kryo-l2-accessors.o
> obj-$(CONFIG_QCOM_ICC_BWMON) += icc-bwmon.o
> -obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE) += ice.o
> +obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE) += qcom-ice.o
> diff --git a/drivers/soc/qcom/ice.c b/drivers/soc/qcom/qcom-ice.c
> similarity index 100%
> rename from drivers/soc/qcom/ice.c
> rename to drivers/soc/qcom/qcom-ice.c
> --
> 2.34.1
>

--
மணிவண்ணன் சதாசிவம்

\
 
 \ /
  Last update: 2023-05-10 10:26    [W:0.041 / U:0.028 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site