lkml.org 
[lkml]   [2023]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH v2 08/14] rcuscale: Rename kfree_rcu() to kfree_rcu_mightsleep()
    Date
    From: "Uladzislau Rezki (Sony)" <urezki@gmail.com>

    The kfree_rcu() and kvfree_rcu() macros' single-argument forms are
    deprecated. Therefore switch to the new kfree_rcu_mightsleep() and
    kvfree_rcu_mightsleep() variants. The goal is to avoid accidental use
    of the single-argument forms, which can introduce functionality bugs in
    atomic contexts and latency bugs in non-atomic contexts.

    Signed-off-by: Uladzislau Rezki (Sony) <urezki@gmail.com>
    Signed-off-by: Paul E. McKenney <paulmck@kernel.org>
    Signed-off-by: Joel Fernandes (Google) <joel@joelfernandes.org>
    ---
    kernel/rcu/rcuscale.c | 2 +-
    1 file changed, 1 insertion(+), 1 deletion(-)

    diff --git a/kernel/rcu/rcuscale.c b/kernel/rcu/rcuscale.c
    index 91fb5905a008..98b75995b680 100644
    --- a/kernel/rcu/rcuscale.c
    +++ b/kernel/rcu/rcuscale.c
    @@ -716,7 +716,7 @@ kfree_scale_thread(void *arg)
    // is tested.
    if ((kfree_rcu_test_single && !kfree_rcu_test_double) ||
    (kfree_rcu_test_both && torture_random(&tr) & 0x800))
    - kfree_rcu(alloc_ptr);
    + kfree_rcu_mightsleep(alloc_ptr);
    else
    kfree_rcu(alloc_ptr, rh);
    }
    --
    2.40.0.rc1.284.g88254d51c5-goog
    \
     
     \ /
      Last update: 2023-03-27 01:01    [W:2.475 / U:0.080 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site