lkml.org 
[lkml]   [2023]   [Oct]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    SubjectRe: [PATCH v3 1/3] pwm: make it possible to apply pwm changes in atomic context
    From
    Hi Uwe,

    On 10/19/23 12:51, Uwe Kleine-König wrote:
    > On Wed, Oct 18, 2023 at 03:57:48PM +0200, Hans de Goede wrote:
    >> Hi Sean,
    >>
    >> On 10/17/23 11:17, Sean Young wrote:
    >>> Some drivers require sleeping, for example if the pwm device is connected
    >>> over i2c. The pwm-ir-tx requires precise timing, and sleeping causes havoc
    >>> with the generated IR signal when sleeping occurs.
    >>>
    >>> This patch makes it possible to use pwm when the driver does not sleep,
    >>> by introducing the pwm_can_sleep() function.
    >>>
    >>> Signed-off-by: Sean Young <sean@mess.org>
    >>
    >> I have no objection to this patch by itself, but it seems a bit
    >> of unnecessary churn to change all current callers of pwm_apply_state()
    >> to a new API.
    >
    > The idea is to improve the semantic of the function name, see
    > https://lore.kernel.org/linux-pwm/20231013180449.mcdmklbsz2rlymzz@pengutronix.de
    > for more context.

    Hmm, so the argument here is that the GPIO API has this, but GPIOs
    generally speaking can be set atomically, so there not being able
    to set it atomically is special.

    OTOH we have many many many other kernel functions which may sleep
    and we don't all postfix them with _can_sleep.

    And for PWM controllers pwm_apply_state is IMHO sorta expected to
    sleep. Many of these are attached over I2C so things will sleep,
    others have a handshake to wait for the current dutycycle to
    end before you can apply a second change on top of an earlier
    change during the current dutycycle which often also involves
    sleeping.

    So the natural/expeected thing for pwm_apply_state() is to sleep
    and thus it does not need a postfix for this IMHO.

    > I think it's very subjective if you consider this
    > churn or not.

    I consider it churn because I don't think adding a postfix
    for what is the default/expected behavior is a good idea
    (with GPIOs not sleeping is the expected behavior).

    I agree that this is very subjective and very much goes
    into the territory of bikeshedding. So please consider
    the above my 2 cents on this and lets leave it at that.

    > While it's nice to have every caller converted in a single
    > step, I'd go for
    >
    > #define pwm_apply_state(pwm, state) pwm_apply_cansleep(pwm, state)
    >
    > , keep that macro for a while and convert all users step by step. This
    > way we don't needlessly break oot code and the changes to convert to the
    > new API can go via their usual trees without time pressure.

    I don't think there are enough users of pwm_apply_state() to warrant
    such an exercise.

    So if people want to move ahead with the _can_sleep postfix addition
    (still not a fan) here is my acked-by for the drivers/platform/x86
    changes, for merging this through the PWM tree in a single commit:

    Acked-by: Hans de Goede <hdegoede@redhat.com>

    Regards,

    Hans


    \
     
     \ /
      Last update: 2023-10-21 11:09    [W:5.402 / U:0.516 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site