lkml.org 
[lkml]   [2023]   [Oct]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 4/5] Staging: sm750fb: Rename programModeRegisters
On Mon, Oct 16, 2023 at 11:14:11PM +0300, Dorcas AnonoLitunya wrote:
> Rename function programModeRegisters to program_mode_registers. This
> follows snakecase naming convention and ensures a consistent naming style
> throughout the file. Issue found by checkpatch.
>
> Mutes the following checkpatch error:
> CHECK: Avoid CamelCase: <programModeRegisters>
>
> Signed-off-by: Dorcas AnonoLitunya <anonolitunya@gmail.com>
> ---
> drivers/staging/sm750fb/ddk750_mode.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/sm750fb/ddk750_mode.c b/drivers/staging/sm750fb/ddk750_mode.c
> index fc3db09de9ae..e901855fa9b6 100644
> --- a/drivers/staging/sm750fb/ddk750_mode.c
> +++ b/drivers/staging/sm750fb/ddk750_mode.c
> @@ -75,8 +75,8 @@ display_control_adjust_SM750LE(struct mode_parameter *mode_param,
> }
>
> /* only timing related registers will be programed */
> -static int programModeRegisters(struct mode_parameter *mode_param,
> - struct pll_value *pll)
> +static int program_mode_registers(struct mode_parameter *mode_param,
> + struct pll_value *pll)
> {
> int ret = 0;
> int cnt = 0;
> @@ -220,6 +220,6 @@ int ddk750_setModeTiming(struct mode_parameter *parm, enum clock_type clock)
> outb_p(0x88, 0x3d4);
> outb_p(0x06, 0x3d5);
> }
> - programModeRegisters(parm, &pll);
> + program_mode_registers(parm, &pll);

Again, the return value is ignored?

\
 
 \ /
  Last update: 2023-10-17 09:51    [W:0.056 / U:0.248 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site