lkml.org 
[lkml]   [2023]   [Jan]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] android: fix W=1 kernel-doc warnings
On Thu, Jan 12, 2023 at 10:36:17PM -0800, Randy Dunlap wrote:
> Clean up kernel-doc notation, use correct function and parameter
> names.
>
> drivers/android/binderfs.c:236: warning: expecting prototype for binderfs_ctl_ioctl(). Prototype was for binder_ctl_ioctl() instead
> drivers/android/binder.c:386: warning: expecting prototype for binder_node_unlock(). Prototype was for binder_node_inner_unlock() instead
> drivers/android/binder.c:1206: warning: expecting prototype for binder_dec_ref(). Prototype was for binder_dec_ref_olocked() instead
> drivers/andrond/binder.c:284: warning: Excess function parameter 'proc' description in 'binder_proc_unlock'
> drivers/andrond/binder.c:387: warning: expecting prototype for binder_node_unlock(). Prototype was for binder_node_inner_unlock() instead
>
> Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
> Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
> Cc: Arve Hjønnevåg <arve@android.com>
> Cc: Todd Kjos <tkjos@android.com>
> Cc: Martijn Coenen <maco@android.com>
> Cc: Joel Fernandes <joel@joelfernandes.org>
> Cc: Christian Brauner <christian@brauner.io>
> Cc: Carlos Llamas <cmllamas@google.com>
> Cc: Suren Baghdasaryan <surenb@google.com>
> ---
> drivers/android/binder.c | 16 ++++++++--------
> drivers/android/binderfs.c | 4 ++--
> 2 files changed, 10 insertions(+), 10 deletions(-)
>
> diff -- a/drivers/android/binder.c b/drivers/android/binder.c
> --- a/drivers/android/binder.c
> +++ b/drivers/android/binder.c
> @@ -277,7 +277,7 @@ _binder_proc_lock(struct binder_proc *pr
>
> /**
> * binder_proc_unlock() - Release spinlock for given binder_proc
> - * @proc: struct binder_proc to acquire
> + * @_proc: struct binder_proc to acquire

I think we could rename the parameter to "proc" instead. This aligns
with the other macros defined here. Aside from this minor nit:

Acked-by: Carlos Llamas <cmllamas@google.com>

Thanks Randy.

\
 
 \ /
  Last update: 2023-03-26 23:41    [W:0.042 / U:0.280 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site