lkml.org 
[lkml]   [2022]   [Sep]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 1/5] device property: Keep dev_fwnode() and dev_fwnode_const() separate
On Wed, Sep 28, 2022 at 01:57:42PM +0300, Andy Shevchenko wrote:
> It's not fully correct to take a const parameter pointer to a struct
> and return a non-const pointer to a member of that struct.
>
> Instead, introduce a const version of the dev_fwnode() API which takes
> and returns const pointers and use it where it's applicable.
>
> Suggested-by: Sakari Ailus <sakari.ailus@linux.intel.com>
> Fixes: aade55c86033 ("device property: Add const qualifier to device_get_match_data() parameter")
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> Acked-by: Heikki Krogerus <heikki.krogerus@linux.intel.com>
> Reviewed-by: Sakari Ailus <sakari.ailus@linux.intel.com>
> ---
> drivers/base/property.c | 11 +++++++++--
> include/linux/property.h | 3 ++-
> 2 files changed, 11 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/base/property.c b/drivers/base/property.c
> index 4d6278a84868..699f1b115e0a 100644
> --- a/drivers/base/property.c
> +++ b/drivers/base/property.c
> @@ -17,13 +17,20 @@
> #include <linux/property.h>
> #include <linux/phy.h>
>
> -struct fwnode_handle *dev_fwnode(const struct device *dev)
> +struct fwnode_handle *dev_fwnode(struct device *dev)
> {
> return IS_ENABLED(CONFIG_OF) && dev->of_node ?
> of_fwnode_handle(dev->of_node) : dev->fwnode;
> }
> EXPORT_SYMBOL_GPL(dev_fwnode);
>
> +const struct fwnode_handle *dev_fwnode_const(const struct device *dev)
> +{
> + return IS_ENABLED(CONFIG_OF) && dev->of_node ?
> + of_fwnode_handle(dev->of_node) : dev->fwnode;
> +}
> +EXPORT_SYMBOL_GPL(dev_fwnode_const);

Ick, no, this is a mess.

Either always return a const pointer, or don't. Ideally always return a
const pointer, so all we really need is:

const struct fwnode_handle *dev_fwnode(const struct device *dev);

right?

Yes, it will take some unwinding backwards to get there, but please do
that instead of having 2 different functions where the parameter type is
part of the function name. This isn't the 1980's...

thanks,

greg k-h

\
 
 \ /
  Last update: 2022-09-28 13:09    [W:0.055 / U:1.736 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site