lkml.org 
[lkml]   [2022]   [Sep]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v1 04/16] ufs: core: mcq: Introduce Multi Circular Queue
On Mon, Sep 26 2022 at 07:50 -0700, Manivannan Sadhasivam wrote:
>On Thu, Sep 22, 2022 at 06:05:11PM -0700, Asutosh Das wrote:

[...]

>> diff --git a/drivers/ufs/core/ufs-mcq.c b/drivers/ufs/core/ufs-mcq.c
>> new file mode 100644
>> index 0000000..934556f
>> --- /dev/null
>> +++ b/drivers/ufs/core/ufs-mcq.c
[...]
>> +static int ufshcd_mcq_config_nr_queues(struct ufs_hba *hba)
>> +{
>> + int i, rem;
>> + u32 hbaq_cap, cmp, tot_queues;
>> + struct Scsi_Host *host = hba->host;
>> +
>> + hbaq_cap = hba->mcq_capabilities & 0xff;
>
>Define 0xff
>
>hbaq_cap should be named after the define used for 0xff. It is not quite
>understandable now.
>
Ok. I think you want the name hbaq_cap to be changed to what 0xff signifies.
Is that understanding correct?

>> +
>> + if (!rw_queues)
>> + rw_queues = num_possible_cpus();
>> +
>> + tot_queues = dev_cmd_queue + read_queues + poll_queues + rw_queues;
>> + if (hbaq_cap < tot_queues) {
>> + dev_err(hba->dev, "Total queues (%d) exceeds HC capacity (%d)\n",
>> + tot_queues, hbaq_cap);
>> + return -EOPNOTSUPP;
>> + }
>> +
>> + rem = hbaq_cap - dev_cmd_queue;
>> + cmp = rem;
>> + hba->nr_queues[HCTX_TYPE_DEFAULT] = min3(cmp, rw_queues,
>> + num_possible_cpus());
>> + rem -= hba->nr_queues[HCTX_TYPE_DEFAULT];
>> + cmp = rem;
>> + hba->nr_queues[HCTX_TYPE_POLL] = min(cmp, poll_queues);
>
>Hmm, so the driver is not using the number of queues set by the user?
>If the number varies, I don't think it should be configurable.
>
I think the driver would use the number of queues set by the user.
Because there's a check(hbaq_cap < tot_queues) above that ensures
that the HBA has enough queues for the given configuration.

-asd

>

\
 
 \ /
  Last update: 2022-09-26 23:34    [W:0.078 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site