lkml.org 
[lkml]   [2022]   [Sep]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Date
    SubjectRe: [PATCH v2] overflow: Introduce overflows_type() and castable_to_type()
    + Arnd

    On Mon, Sep 26, 2022 at 12:11 PM Kees Cook <keescook@chromium.org> wrote:
    > ---
    > v2:
    > - fix comment typo
    > - wrap clang pragma to avoid GCC warnings
    > - style nit cleanups
    > - rename __castable_to_type() to castable_to_type()
    > - remove prior overflows_type() definition
    > v1: https://lore.kernel.org/lkml/20220926003743.409911-1-keescook@chromium.org
    > diff --git a/lib/overflow_kunit.c b/lib/overflow_kunit.c
    > index f385ca652b74..fffc3f86181d 100644
    > --- a/lib/overflow_kunit.c
    > +++ b/lib/overflow_kunit.c
    > @@ -16,6 +16,11 @@
    > #include <linux/types.h>
    > #include <linux/vmalloc.h>
    >
    > +/* We're expecting to do a lot of "always true" or "always false" tests. */
    > +#ifdef CONFIG_CC_IS_CLANG
    > +#pragma clang diagnostic ignored "-Wtautological-constant-out-of-range-compare"
    > +#endif

    Any chance we can reuse parts of __diag_ignore or __diag_clang from
    include/linux/compiler_types.h or include/linux/compiler-clang.h
    respectively?

    Those are needed for pragmas within preprocessor macros, which we
    don't have here, but I suspect they may be more concise to use here.

    > +#define TEST_SAME_TYPE(t1, t2, same) do { \
    > + typeof(t1) __t1h = type_max(t1); \
    > + typeof(t1) __t1l = type_min(t1); \
    > + typeof(t2) __t2h = type_max(t2); \
    > + typeof(t2) __t2l = type_min(t2); \

    Can we use __auto_type here rather than typeof(macro expansion)?
    --
    Thanks,
    ~Nick Desaulniers

    \
     
     \ /
      Last update: 2022-09-26 22:18    [W:3.045 / U:0.152 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site