lkml.org 
[lkml]   [2022]   [Sep]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
SubjectRe: [PATCH v2 04/33] drm/connector: Rename subconnector state variable
From
Hi

Am 22.09.22 um 16:25 schrieb Maxime Ripard:
> There is two TV subconnector related properties registered by
> drm_mode_create_tv_properties(): subconnector and select subconnector.
>
> While the select subconnector property is stored in the kernel by the
> drm_tv_connector_state structure, the subconnector property isn't stored
> anywhere.
>
> Worse, the select subconnector property is stored in a field called
> subconnector, creating some ambiguity about which property content we're
> accessing.
>
> Let's rename that field to one called select_subconnector to make it move
> obvious what it's about.

Is this the place where that extra chuck in patch 3 belong to?

>
> Reviewed-by: Noralf Trønnes <noralf@tronnes.org>
> Signed-off-by: Maxime Ripard <maxime@cerno.tech>

Acked-by: Thomas Zimmermann <tzimmermann@suse.de>

>
> diff --git a/drivers/gpu/drm/drm_atomic_uapi.c b/drivers/gpu/drm/drm_atomic_uapi.c
> index 79730fa1dd8e..c74c78a28171 100644
> --- a/drivers/gpu/drm/drm_atomic_uapi.c
> +++ b/drivers/gpu/drm/drm_atomic_uapi.c
> @@ -687,7 +687,7 @@ static int drm_atomic_connector_set_property(struct drm_connector *connector,
> */
> return -EINVAL;
> } else if (property == config->tv_select_subconnector_property) {
> - state->tv.subconnector = val;
> + state->tv.select_subconnector = val;
> } else if (property == config->tv_left_margin_property) {
> state->tv.margins.left = val;
> } else if (property == config->tv_right_margin_property) {
> @@ -795,7 +795,7 @@ drm_atomic_connector_get_property(struct drm_connector *connector,
> else
> *val = connector->dpms;
> } else if (property == config->tv_select_subconnector_property) {
> - *val = state->tv.subconnector;
> + *val = state->tv.select_subconnector;
> } else if (property == config->tv_left_margin_property) {
> *val = state->tv.margins.left;
> } else if (property == config->tv_right_margin_property) {
> diff --git a/include/drm/drm_connector.h b/include/drm/drm_connector.h
> index 23112f0c11cf..60b5662dec7c 100644
> --- a/include/drm/drm_connector.h
> +++ b/include/drm/drm_connector.h
> @@ -703,7 +703,7 @@ struct drm_connector_tv_margins {
> * @hue: hue in percent
> */
> struct drm_tv_connector_state {
> - enum drm_mode_subconnector subconnector;
> + enum drm_mode_subconnector select_subconnector;
> struct drm_connector_tv_margins margins;
> unsigned int mode;
> unsigned int brightness;
>

--
Thomas Zimmermann
Graphics Driver Developer
SUSE Software Solutions Germany GmbH
Maxfeldstr. 5, 90409 Nürnberg, Germany
(HRB 36809, AG Nürnberg)
Geschäftsführer: Ivo Totev
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2022-09-23 10:15    [W:0.047 / U:0.292 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site