lkml.org 
[lkml]   [2022]   [Sep]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH -next 2/3] fail_function: refctor code of checking return value of register_kprobe()
On Fri, 26 Aug 2022 15:33:36 +0800
Yang Yingliang <yangyingliang@huawei.com> wrote:

> Refactor the error handling of register_kprobe() to improve readability.
> No functional change.
>
> Signed-off-by: Yang Yingliang <yangyingliang@huawei.com>

OK, but in this case, could you fold [2/3] and [3/3], because
[3/3] can not be applied without this change.

Thank you,

> ---
> kernel/fail_function.c | 11 +++++------
> 1 file changed, 5 insertions(+), 6 deletions(-)
>
> diff --git a/kernel/fail_function.c b/kernel/fail_function.c
> index 03643e33e4c3..893e8f9a9118 100644
> --- a/kernel/fail_function.c
> +++ b/kernel/fail_function.c
> @@ -294,14 +294,13 @@ static ssize_t fei_write(struct file *file, const char __user *buffer,
> }
>
> ret = register_kprobe(&attr->kp);
> - if (!ret)
> - fei_debugfs_add_attr(attr);
> - if (ret < 0)
> + if (ret) {
> fei_attr_remove(attr);
> - else {
> - list_add_tail(&attr->list, &fei_attr_list);
> - ret = count;
> + goto out;
> }
> + fei_debugfs_add_attr(attr);
> + list_add_tail(&attr->list, &fei_attr_list);
> + ret = count;
> out:
> mutex_unlock(&fei_lock);
> kfree(buf);
> --
> 2.25.1
>


--
Masami Hiramatsu (Google) <mhiramat@kernel.org>

\
 
 \ /
  Last update: 2022-09-12 11:38    [W:0.184 / U:0.616 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site