lkml.org 
[lkml]   [2022]   [Aug]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v2 1/2] ARM: msm8960: Rename cxo_board to cxo-board and add alias
From
On 09/08/2022 03:02, Rudraksha Gupta wrote:
> This patch renames cxo_board to be up to date with the current naming
> style. It also adds an alias.

Same comment as v1.

Additionally you do not explain why you are doing it.

>
> Signed-off-by: Rudraksha Gupta <guptarud@gmail.com>
> ---
> v2:
> - Group the correct changes together

Don't link new patchsets to some other threads.
>
> arch/arm/boot/dts/qcom-msm8960.dtsi | 2 +-
> drivers/clk/qcom/gcc-msm8960.c | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/arm/boot/dts/qcom-msm8960.dtsi b/arch/arm/boot/dts/qcom-msm8960.dtsi
> index 0e099aa7c889..2ed969785b78 100644
> --- a/arch/arm/boot/dts/qcom-msm8960.dtsi
> +++ b/arch/arm/boot/dts/qcom-msm8960.dtsi
> @@ -58,7 +58,7 @@ cpu-pmu {
> };
>
> clocks {
> - cxo_board {
> + cxo_board: cxo-board {
> compatible = "fixed-clock";
> #clock-cells = <0>;
> clock-frequency = <19200000>;
> diff --git a/drivers/clk/qcom/gcc-msm8960.c b/drivers/clk/qcom/gcc-msm8960.c
> index 051745ef99c8..56ce05a846dd 100644
> --- a/drivers/clk/qcom/gcc-msm8960.c
> +++ b/drivers/clk/qcom/gcc-msm8960.c
> @@ -3624,7 +3624,7 @@ static int gcc_msm8960_probe(struct platform_device *pdev)
> if (!match)
> return -EINVAL;
>
> - ret = qcom_cc_register_board_clk(dev, "cxo_board", "cxo", 19200000);
> + ret = qcom_cc_register_board_clk(dev, "cxo-board", "cxo", 19200000);


My comment from v1 still applies - this does not match subsystem.
Additionally DTS change and driver change *cannot* go together.
Basically your commit is non-bisectable which is indication it is not
correct approach.

Best regards,
Krzysztof

\
 
 \ /
  Last update: 2022-08-09 07:33    [W:0.143 / U:1.044 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site