lkml.org 
[lkml]   [2022]   [Aug]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 3/3] lib/find_bit: optimize find_next_bit() functions
On Wed, Aug 24, 2022 at 08:56:02PM +0300, Andy Shevchenko wrote:
> On Wed, Aug 24, 2022 at 8:54 PM Andy Shevchenko
> <andy.shevchenko@gmail.com> wrote:
> > On Wed, Aug 24, 2022 at 4:53 PM Yury Norov <yury.norov@gmail.com> wrote:
> > > On Wed, Aug 24, 2022 at 12:19:05PM +0300, Andy Shevchenko wrote:
> > > > On Wed, Aug 24, 2022 at 4:56 AM Yury Norov <yury.norov@gmail.com> wrote:
>
> ...
>
> > > > > +#define FIND_NEXT_BIT(EXPRESSION, size, start) \
> > > > > +({ \
> > > > > + unsigned long mask, idx, tmp, sz = (size), __start = (start); \
> > > > > + \
> > > > > + if (unlikely(__start >= sz)) \
> > > > > + goto out; \
> > > > > + \
> > > > > + mask = word_op(BITMAP_FIRST_WORD_MASK(__start)); \
> > > > > + idx = __start / BITS_PER_LONG; \
> > > > > + \
> > > > > + for (tmp = (EXPRESSION) & mask; !tmp; tmp = (EXPRESSION)) { \
> > > >
> > > > for (unsigned long tmp ...;
> > > > But hey, why not loop over idx (which probably should be named as
> > > > offset)
> > >
> > > Offset in structure, index in array, isn't?
> > >
> > > > as I proposed in the first patch? You will drop a lot of
> > > > divisions / multiplications, no?
> > >
> > > Those divisions and multiplications are optimized away, and
> > > what you suggested blows up the EXPRESSION.
> > >
> > > I tried like this:
> > > mask = word_op(BITMAP_FIRST_WORD_MASK(__start));
> > > idx = __start / BITS_PER_LONG;
> > > tmp = (EXPRESSION);
> > >
> > > while (1) {
> > > if (tmp) {
> > > sz = min(idx * BITS_PER_LONG + __ffs(word_op(tmp)), sz);
> > > break;
> > > }
> > >
> > > if (++idx > sz)
> > > break;
> > >
> > > tmp = (EXPRESSION);
> > > }
> > >
> > > And it generated the same code, but looks less expressive to me.
> > > If you have some elegant approach in mind - can you please share
> > > it, and how the generated code looks?
> >
> > for (unsigned long idx = 0; idx < sz; idx++) {
>
> Of source 0 should be changed to whatever start you have there.
>
> > unsigned long tmp;
> >
> > tmp = (EXPRESSION);
> > if (tmp) {
> > ...
> > }
> > }
> >
> > No?

No. For the first iteration, the tmp can't be calculated inside the loop
(my example above is wrong) because we need to clear first bits:

mask = BITMAP_FIRST_WORD_MASK(__start);
idx = __start / BITS_PER_LONG;
tmp = (EXPRESSION) & mask; // First fetch is here

while (1) {
if (tmp) { // Evaluate here
sz = min(idx * BITS_PER_LONG + __ffs(tmp), sz);
break;
}

if (++idx > sz) // Increment here
break;

tmp = (EXPRESSION); // Other fetches here
}

Trying to move iterator increment inside the for-loop, like you suggested
would break the sequence - common-case word fetch will happen before the
idx++.

\
 
 \ /
  Last update: 2022-08-24 23:28    [W:0.244 / U:0.100 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site