[lkml]   [2022]   [Aug]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v5] ufs: core: print UFSHCD capabilities in controller's sysfs node
On 8/1/22 21:12, Daniil Lunev wrote:
>> Calling this the effective capabilities of the controller-device pair
>> sounds good to me. But please do not refer to hba->caps. I'd like to
>> rework hba->caps such that it only includes controller capabilities and
>> no information related to the WriteBooster. Additionally, several UFS
>> device capabilities that may be exported in the future are not
>> represented in hba->caps.
> So can you clarify where specifically do you want me to mention that?
> Should I name the directory "effective_capabilities" or the commit
> message?

I'm fine with the name "capabilities" since "effective_capabilities" is
a bit long.

How about adding the above explanation in the source code close to the
definition of the capabilities group since it is more likely that it
will be noticed there by software developers compared to Documentation/ABI/?



 \ /
  Last update: 2022-08-02 19:32    [W:0.071 / U:0.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site