lkml.org 
[lkml]   [2022]   [Aug]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [Patch RFC net-next 1/4] net: dsa: microchip: modify vlan_add function prototype
Date
Hi Vladimir,
Thanks for the comment

On Tue, 2022-08-02 at 13:32 +0300, Vladimir Oltean wrote:
> EXTERNAL EMAIL: Do not click links or open attachments unless you
> know the content is safe
>
> On Fri, Jul 29, 2022 at 08:47:30PM +0530, Arun Ramadoss wrote:
> > diff --git a/drivers/net/dsa/microchip/ksz8.h
> > b/drivers/net/dsa/microchip/ksz8.h
> > index 42c50cc4d853..6529f2e2426a 100644
> > --- a/drivers/net/dsa/microchip/ksz8.h
> > +++ b/drivers/net/dsa/microchip/ksz8.h
> > @@ -38,9 +38,8 @@ int ksz8_mdb_del(struct ksz_device *dev, int
> > port,
> > const struct switchdev_obj_port_mdb *mdb, struct
> > dsa_db db);
> > int ksz8_port_vlan_filtering(struct ksz_device *dev, int port,
> > bool flag,
> > struct netlink_ext_ack *extack);
> > -int ksz8_port_vlan_add(struct ksz_device *dev, int port,
> > - const struct switchdev_obj_port_vlan *vlan,
> > - struct netlink_ext_ack *extack);
> > +int ksz8_port_vlan_add(struct ksz_device *dev, int port, u16
> > vlan_vid,
>
> I don't see an impediment to naming "vlan_vid" just "vid".

Ok, I will name it as vid.

>
> > + u16 flags);
> > int ksz8_port_vlan_del(struct ksz_device *dev, int port,
> > const struct switchdev_obj_port_vlan *vlan);
>
> Won't you convert vlan_del too?

I will change it too.

\
 
 \ /
  Last update: 2022-08-02 15:59    [W:0.346 / U:2.080 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site