lkml.org 
[lkml]   [2022]   [Aug]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v2 1/5] bitops: Introduce find_next_andnot_bit()
On Thu, Aug 18, 2022 at 8:18 PM Steven Rostedt <rostedt@goodmis.org> wrote:
> On Thu, 18 Aug 2022 17:26:43 +0100
> Valentin Schneider <vschneid@redhat.com> wrote:
>
> > How about:
>
> >
> > find the next set bit in (*addr1 & ~*addr2)
>
> I understand the above better. But to convert that into English, we could
> say:
>
>
> Find the next bit in *addr1 excluding all the bits in *addr2.
>
> or
>
> Find the next bit in *addr1 that is not set in *addr2.

With this explanation I'm wondering how different this is to
bitmap_bitremap(), with adjusting to using an inverted mask. If they
have something in common, perhaps make them in the same namespace with
similar naming convention?

--
With Best Regards,
Andy Shevchenko

\
 
 \ /
  Last update: 2022-08-18 21:06    [W:0.261 / U:0.948 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site