lkml.org 
[lkml]   [2022]   [Aug]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] ASoC: intel: Replace scnprintf() calls with sysfs_emit_at()
On Tue, 16 Aug 2022 10:55:02 +0200,
zhaoxiao wrote:
>
> For sysfs outputs, it's safer to use a new helper, sysfs_emit(),
> instead of the raw sprintf() & co. This patch replaces the open-code
> with a new helper, sysfs_emit_at(), by passing the string offset.

Well, the function you've changed isn't used for sysfs at all...


Takashi

>
> Signed-off-by: zhaoxiao <zhaoxiao@uniontech.com>
> ---
> sound/soc/sof/intel/hda.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/sound/soc/sof/intel/hda.c b/sound/soc/sof/intel/hda.c
> index 6d4ecbe14adf..917d639671a7 100644
> --- a/sound/soc/sof/intel/hda.c
> +++ b/sound/soc/sof/intel/hda.c
> @@ -574,7 +574,7 @@ static void hda_dsp_dump_ext_rom_status(struct snd_sof_dev *sdev, const char *le
> chip = get_chip_info(sdev->pdata);
> for (i = 0; i < HDA_EXT_ROM_STATUS_SIZE; i++) {
> value = snd_sof_dsp_read(sdev, HDA_DSP_BAR, chip->rom_status_reg + i * 0x4);
> - len += scnprintf(msg + len, sizeof(msg) - len, " 0x%x", value);
> + len += sysfs_emit_at(msg, len, " 0x%x", value);
> }
>
> dev_printk(level, sdev->dev, "extended rom status: %s", msg);
> --
> 2.20.1
>

\
 
 \ /
  Last update: 2022-08-16 12:42    [W:0.029 / U:0.108 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site