lkml.org 
[lkml]   [2022]   [Jul]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH] soc: amlogic: meson-pwrc: Hold reference returned by of_get_parent()
Hello,

thank you for your patch!

On Tue, Jul 5, 2022 at 4:20 AM Liang He <windhl@126.com> wrote:
[...]
> + struct device_node *np;
>
> int i, ret;
>
> match = of_device_get_match_data(&pdev->dev);
> @@ -495,7 +496,9 @@ static int meson_ee_pwrc_probe(struct platform_device *pdev)
>
> pwrc->xlate.num_domains = match->count;
>
> - regmap_hhi = syscon_node_to_regmap(of_get_parent(pdev->dev.of_node));
> + np = of_get_parent(pdev->dev.of_node);
> + regmap_hhi = syscon_node_to_regmap(np);
This works but I had to read the code twice because I thought the
wrong struct device_node was used.
Other drivers typically use "np" for whatever the code section
currently refers to. In this case the code section is about the power
controller, so I thought that "np" was the same as
"pdev->dev.of_node".

I think the code would be easier to understand and the likelihood of
someone making the same mistake as I did if you could rename "np" to
"parent_np" (just like you have done in your other patches).

[...]
> + struct device_node *np;
same as above, I suggest renaming this to parent_np.

\
 
 \ /
  Last update: 2022-07-25 21:47    [W:0.050 / U:1.296 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site