lkml.org 
[lkml]   [2022]   [Jul]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2] USB: serial: usb_wwan: replace DTR/RTS magic numbers with macros
On Fri, Jul 22, 2022 at 10:40:51AM +0800, Yan Xinyu wrote:
> > On Jul 22, 2022, at 02:18, Greg KH <gregkh@linuxfoundation.org> wrote:
> >
> > On Thu, Jul 21, 2022 at 11:52:57PM +0800, Yan Xinyu wrote:
> >> The usb_wwan_send_setup function generates DTR/RTS signals in compliance
> >> with CDC ACM standard. This patch changes magic numbers in this function
> >> to equivalent macros.
> >>
> >> Signed-off-by: Yan Xinyu <sdlyyxy@bupt.edu.cn>
> >> ---
> >> v1->v2:
> >> * Fix Signed-off-by name.
> >> ---
> >> drivers/usb/serial/usb_wwan.c | 13 +++++++++----
> >> 1 file changed, 9 insertions(+), 4 deletions(-)
> >>
> >> diff --git a/drivers/usb/serial/usb_wwan.c b/drivers/usb/serial/usb_wwan.c
> >> index dab38b63eaf7..a6bd6144702d 100644
> >> --- a/drivers/usb/serial/usb_wwan.c
> >> +++ b/drivers/usb/serial/usb_wwan.c
> >> @@ -29,10 +29,14 @@
> >> #include <linux/bitops.h>
> >> #include <linux/uaccess.h>
> >> #include <linux/usb.h>
> >> +#include <linux/usb/cdc.h>
> >> #include <linux/usb/serial.h>
> >> #include <linux/serial.h>
> >> #include "usb-wwan.h"
> >>
> >> +#define ACM_CTRL_DTR 0x01
> >> +#define ACM_CTRL_RTS 0x02
> >
> > Why are these not in the cdc.h file already?
>
> These are defined in the drivers/usb/class/cdc-acm.h file. Is it safe
> to include it?

Yes, of course!

\
 
 \ /
  Last update: 2022-07-22 09:05    [W:0.046 / U:0.496 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site