lkml.org 
[lkml]   [2022]   [Jul]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] USB: serial: usb_wwan: replace DTR/RTS magic numbers with macros
On Thu, Jul 21, 2022 at 11:23:35PM +0800, sdlyyxy wrote:
> The usb_wwan_send_setup function generates DTR/RTS signals in compliance
> with CDC ACM standard. This patch changes magic numbers in this function
> to equivalent macros.
>
> Signed-off-by: sdlyyxy <sdlyyxy@bupt.edu.cn>
> ---
> drivers/usb/serial/usb_wwan.c | 13 +++++++++----
> 1 file changed, 9 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/usb/serial/usb_wwan.c b/drivers/usb/serial/usb_wwan.c
> index dab38b63eaf7..a6bd6144702d 100644
> --- a/drivers/usb/serial/usb_wwan.c
> +++ b/drivers/usb/serial/usb_wwan.c
> @@ -29,10 +29,14 @@
> #include <linux/bitops.h>
> #include <linux/uaccess.h>
> #include <linux/usb.h>
> +#include <linux/usb/cdc.h>
> #include <linux/usb/serial.h>
> #include <linux/serial.h>
> #include "usb-wwan.h"
>
> +#define ACM_CTRL_DTR 0x01
> +#define ACM_CTRL_RTS 0x02
> +
> /*
> * Generate DTR/RTS signals on the port using the SET_CONTROL_LINE_STATE request
> * in CDC ACM.
> @@ -48,9 +52,9 @@ static int usb_wwan_send_setup(struct usb_serial_port *port)
> portdata = usb_get_serial_port_data(port);
>
> if (portdata->dtr_state)
> - val |= 0x01;
> + val |= ACM_CTRL_DTR;
> if (portdata->rts_state)
> - val |= 0x02;
> + val |= ACM_CTRL_RTS;
>
> ifnum = serial->interface->cur_altsetting->desc.bInterfaceNumber;
>
> @@ -59,8 +63,9 @@ static int usb_wwan_send_setup(struct usb_serial_port *port)
> return res;
>
> res = usb_control_msg(serial->dev, usb_sndctrlpipe(serial->dev, 0),
> - 0x22, 0x21, val, ifnum, NULL, 0,
> - USB_CTRL_SET_TIMEOUT);
> + USB_CDC_REQ_SET_CONTROL_LINE_STATE,
> + USB_DIR_OUT | USB_TYPE_CLASS | USB_RECIP_INTERFACE,
> + val, ifnum, NULL, 0, USB_CTRL_SET_TIMEOUT);
>
> usb_autopm_put_interface(port->serial->interface);
>
> --
> 2.25.1
>
>
>

Hi,

This is the friendly patch-bot of Greg Kroah-Hartman. You have sent him
a patch that has triggered this response. He used to manually respond
to these common problems, but in order to save his sanity (he kept
writing the same thing over and over, yet to different people), I was
created. Hopefully you will not take offence and will fix the problem
in your patch and resubmit it so that it can be accepted into the Linux
kernel tree.

You are receiving this message because of the following common error(s)
as indicated below:

- It looks like you did not use your "real" name for the patch on either
the Signed-off-by: line, or the From: line (both of which have to
match). Please read the kernel file, Documentation/SubmittingPatches
for how to do this correctly.

If you wish to discuss this problem further, or you have questions about
how to resolve this issue, please feel free to respond to this email and
Greg will reply once he has dug out from the pending patches received
from other developers.

thanks,

greg k-h's patch email bot

\
 
 \ /
  Last update: 2022-07-21 20:18    [W:0.132 / U:0.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site