lkml.org 
[lkml]   [2022]   [Jul]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH 1/4] s390/cio: Rename bitmap_size() as idset_bitmap_size()
    On Sat, Jul 02, 2022 at 08:29:09PM +0200, Christophe JAILLET wrote:
    > In order to introduce a bitmap_size() function in the bitmap API, we have
    > to rename functions with a similar name.
    >
    > Add a "idset_" prefix and change bitmap_size() into idset_bitmap_size().
    >
    > No functional change.

    ...

    > - memset(set->bitmap, 0, bitmap_size(num_ssid, num_id));
    > + memset(set->bitmap, 0, idset_bitmap_size(num_ssid, num_id));

    Why not to use bitmap_zero()?

    ...

    > - memset(set->bitmap, 0xff, bitmap_size(set->num_ssid, set->num_id));
    > + memset(set->bitmap, 0xff, idset_bitmap_size(set->num_ssid, set->num_id));

    Why not to use bitmap_fill() ?


    --
    With Best Regards,
    Andy Shevchenko


    \
     
     \ /
      Last update: 2022-07-02 20:55    [W:3.926 / U:0.200 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site