lkml.org 
[lkml]   [2022]   [Jul]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRE: [PATCH v3 2/2] fpga: dfl-pci: Add IDs for Intel N6000, N6001 and C6100 cards


On Mon, 18 Jul 2022, Wu, Hao wrote:

>> -----Original Message-----
>> From: matthew.gerlach@linux.intel.com <matthew.gerlach@linux.intel.com>
>> Sent: Thursday, July 7, 2022 11:06 PM
>> To: Wu, Hao <hao.wu@intel.com>; Xu, Yilun <yilun.xu@intel.com>; Weight,
>> Russell H <russell.h.weight@intel.com>; Muddebihal, Basheer Ahmed
>> <basheer.ahmed.muddebihal@intel.com>; trix@redhat.com;
>> mdf@kernel.org; corbet@lwn.net; linux-fpga@vger.kernel.org; linux-
>> doc@vger.kernel.org; linux-kernel@vger.kernel.org; Zhang, Tianfei
>> <tianfei.zhang@intel.com>
>> Cc: Matthew Gerlach <matthew.gerlach@linux.intel.com>
>> Subject: [PATCH v3 2/2] fpga: dfl-pci: Add IDs for Intel N6000, N6001 and
>> C6100 cards
>>
>> From: Matthew Gerlach <matthew.gerlach@linux.intel.com>
>>
>> Add pci_dev_table entries supporting the Intel N6000, N6001
>> and C6100 cards to the dfl-pci driver.
>>
>> Signed-off-by: Matthew Gerlach <matthew.gerlach@linux.intel.com>
>> Signed-off-by: Tianfei Zhang <tianfei.zhang@intel.com>
>> ---
>> v3: added necessary subdevice ids
>> removed 'drivers: ' from title
>>
>> v2: changed names from INTEL_OFS to INTEL_DFL
>> ---
>> drivers/fpga/dfl-pci.c | 19 +++++++++++++++++++
>> 1 file changed, 19 insertions(+)
>>
>> diff --git a/drivers/fpga/dfl-pci.c b/drivers/fpga/dfl-pci.c
>> index fd1fa55c9113..94eabdf1d2f7 100644
>> --- a/drivers/fpga/dfl-pci.c
>> +++ b/drivers/fpga/dfl-pci.c
>> @@ -77,12 +77,19 @@ static void cci_pci_free_irq(struct pci_dev *pcidev)
>> #define PCIE_DEVICE_ID_INTEL_PAC_D5005 0x0B2B
>> #define PCIE_DEVICE_ID_SILICOM_PAC_N5010 0x1000
>> #define PCIE_DEVICE_ID_SILICOM_PAC_N5011 0x1001
>> +#define PCIE_DEVICE_ID_INTEL_DFL 0xbcce
>>
>> /* VF Device */
>> #define PCIE_DEVICE_ID_VF_INT_5_X 0xBCBF
>> #define PCIE_DEVICE_ID_VF_INT_6_X 0xBCC1
>> #define PCIE_DEVICE_ID_VF_DSC_1_X 0x09C5
>> #define PCIE_DEVICE_ID_INTEL_PAC_D5005_VF 0x0B2C
>> +#define PCIE_DEVICE_ID_INTEL_DFL_VF 0xbccf
>> +
>> +/* PCI Subdevice ID */
>> +#define PCIE_SUBDEVICE_ID_INTEL_N6000 0x1770
>> +#define PCIE_SUBDEVICE_ID_INTEL_N6001 0x1771
>> +#define PCIE_SUBDEVICE_ID_INTEL_C6100 0x17d4
>
> Please move SUBDEVICE_ID above together with DEVICE_ID.
> If we add new SUBDEVICE to some other device like this, it will
> be hard to distinguish them.

This is a very good suggestion. I will resubmit with your suggestion.

Thanks for the review.
Matthew
>
> With above change.
> Acked-by: Wu Hao <hao.wu@intel.com>
>
> Thanks
> Hao
>
>

\
 
 \ /
  Last update: 2022-07-18 21:27    [W:0.597 / U:0.168 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site