lkml.org 
[lkml]   [2022]   [Jul]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v2 2/6] gpiolib: cdev: simplify parameter in call to hte_edge_setup
From
On 7/13/22 7:03 PM, Kent Gibson wrote:
> Improve readability by using the GPIO_V2_LINE_FLAG_EDGE_BOTH instead
> of combining the rising and falling edge flags.
>
> Signed-off-by: Kent Gibson <warthog618@gmail.com>
> Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>
> ---
> drivers/gpio/gpiolib-cdev.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/gpio/gpiolib-cdev.c b/drivers/gpio/gpiolib-cdev.c
> index b44526e3630e..f635bbbb6a6d 100644
> --- a/drivers/gpio/gpiolib-cdev.c
> +++ b/drivers/gpio/gpiolib-cdev.c
> @@ -885,9 +885,7 @@ static int debounce_setup(struct line *line,
> return ret;
> line->irq = irq;
> } else {
> - ret = hte_edge_setup(line,
> - GPIO_V2_LINE_FLAG_EDGE_RISING |
> - GPIO_V2_LINE_FLAG_EDGE_FALLING);
> + ret = hte_edge_setup(line, GPIO_V2_LINE_FLAG_EDGE_BOTH);
> if (ret)
> return ret;
> }

Acked-by: Dipen Patel <dipenp@nvidia.com>

\
 
 \ /
  Last update: 2022-07-15 07:11    [W:0.098 / U:0.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site