lkml.org 
[lkml]   [2022]   [Jul]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v2 0/5] mfd: stmpe: Probe sub-function by compatible
Date
Hi all,
This series update the STMPE MFD driver to use of_compatible to probe for
sub-functions instead of using hardcoded names. Matching by name does not seems
in general a good idea, in this specific case it is even worst since the node
name are not compliant to the current naming convention (they are not generic
and they do include underscores), and because of that recently
we had a regression introduced [1].

This change was suggested by Ahmad Fatoum [2].

[1] commit 56086b5e ("ARM: dts: imx6qdl-apalis: Avoid underscore in node name")
[2] https://lore.kernel.org/all/86815346-209e-304e-3565-b4160afa48e8@pengutronix.de/

Changes in v2:
- split in a separate patch the removal of rotator from probe
- remove define usage for compatible strings

Francesco Dolcini (5):
mfd: stmpe: Remove rotator block from probe
mfd: stmpe: Probe sub-function by compatible
dt-bindings: gpio: stmpe: Remove node name requirement
dt-bindings: iio: adc: stmpe: Remove node name requirement
dt-bindings: input: touchscreen: stmpe: Remove node name requirement

.../devicetree/bindings/gpio/gpio-stmpe.txt | 3 +--
.../devicetree/bindings/iio/adc/st,stmpe-adc.yaml | 3 +--
.../devicetree/bindings/input/touchscreen/stmpe.txt | 3 +--
drivers/mfd/stmpe.c | 13 +++++--------
4 files changed, 8 insertions(+), 14 deletions(-)

--
2.25.1

\
 
 \ /
  Last update: 2022-07-12 18:35    [W:0.233 / U:0.548 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site