lkml.org 
[lkml]   [2022]   [Jun]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/1] power: supply: cros_peripheral: Use struct_size() helper in kzalloc()
Hi,

On Tue, Jun 07, 2022 at 11:03:44PM +0800, Xiaohui Zhang wrote:
> Similar to the handling of cros_usbpd_charger_ec_command in commit 441d38c60fbe
> ("power: supply: cros_usbpd: Use struct_size() helper in kzalloc()"),
> we thought a patch might be needed here as well.
>
> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.
>
> Signed-off-by: Xiaohui Zhang <xiaohuizhang@ruc.edu.cn>

Thanks, queued.

-- Sebastian

> drivers/power/supply/cros_peripheral_charger.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/power/supply/cros_peripheral_charger.c b/drivers/power/supply/cros_peripheral_charger.c
> index 9fe6d826148d..1379afd9698d 100644
> --- a/drivers/power/supply/cros_peripheral_charger.c
> +++ b/drivers/power/supply/cros_peripheral_charger.c
> @@ -63,7 +63,7 @@ static int cros_pchg_ec_command(const struct charger_data *charger,
> struct cros_ec_command *msg;
> int ret;
>
> - msg = kzalloc(sizeof(*msg) + max(outsize, insize), GFP_KERNEL);
> + msg = kzalloc(struct_size(msg, data, max(outsize, insize)), GFP_KERNEL);
> if (!msg)
> return -ENOMEM;
>
> --
> 2.17.1
>
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2022-06-09 22:09    [W:0.039 / U:0.628 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site