[lkml]   [2022]   [Jun]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 5/5] mm: ioremap: rename ioremap_page_range() to ioremap_range()
On Mon, Jun 06, 2022 at 04:39:09PM +0800, Baoquan He wrote:
> Because the current ioremap_page_range() only maps IO address to kernel
> virtual address, no struct page pointer passed in or page handling related.
> So rename it here.
> The renaming is done with below command:
> sed -i "s/ioremap_page_range/ioremap_range/g" `git grep -l ioremap_page_range`

This creates a lot of churn without much of a benefit. If you want
to get rid of the name please convert most architectures to the
generioc ioremap code first so that all these callers go away..

 \ /
  Last update: 2022-06-07 07:28    [W:0.154 / U:1.152 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site