[lkml]   [2022]   [Jun]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 5/5] mm: ioremap: rename ioremap_page_range() to ioremap_range()
On 06/06/22 at 10:27pm, Christoph Hellwig wrote:
> On Mon, Jun 06, 2022 at 04:39:09PM +0800, Baoquan He wrote:
> > Because the current ioremap_page_range() only maps IO address to kernel
> > virtual address, no struct page pointer passed in or page handling related.
> > So rename it here.
> >
> > The renaming is done with below command:
> > sed -i "s/ioremap_page_range/ioremap_range/g" `git grep -l ioremap_page_range`
> This creates a lot of churn without much of a benefit. If you want
> to get rid of the name please convert most architectures to the
> generioc ioremap code first so that all these callers go away..

Thanks for checking.

Yeah, I didn't manually adjust those indentation after replacing via
command. While the name of ioremap_page_range() is misleading, relative
to its implementation.

Converting to use generic ioremap code on most of architectures sounds
like a good idea, just like what the arm/arm64 converting patchset is
doing. From a quick look, not all places can take the converting, and
there's one in pci_remap_iospace() under drivers. So what I need to do
is to:

1)take back this pach;
2)convert as many architectures to the generic ioremap code as possible;
3)rename the left places of ioremap_page_range() to ioremap_range().

Please check if this is what you are suggesting.


 \ /
  Last update: 2022-06-07 09:53    [W:0.059 / U:0.128 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site