lkml.org 
[lkml]   [2022]   [Jun]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [RESEND v4 1/3] dt-bindings: mediatek: add vdosys1 RDMA definition for mt8195
From
Date
On Mon, 2022-06-06 at 20:53 +0800, Rob Herring wrote:
> On Mon, 06 Jun 2022 13:11:29 +0800, Bo-Chen Chen wrote:
> > From: "Nancy.Lin" <nancy.lin@mediatek.com>
> >
> > Add vdosys1 RDMA definition.
> >
> > Signed-off-by: Nancy.Lin <nancy.lin@mediatek.com>
> > Signed-off-by: Bo-Chen Chen <rex-bc.chen@mediatek.com>
> > Reviewed-by: AngeloGioacchino Del Regno <
> > angelogioacchino.delregno@collabora.com>
> > Reviewed-by: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
> > Tested-by: AngeloGioacchino Del Regno <
> > angelogioacchino.delregno@collabora.com>
> > ---
> > .../display/mediatek/mediatek,mdp-rdma.yaml | 88
> > +++++++++++++++++++
> > 1 file changed, 88 insertions(+)
> > create mode 100644
> > Documentation/devicetree/bindings/display/mediatek/mediatek,mdp-
> > rdma.yaml
> >
>
> My bot found errors running 'make DT_CHECKER_FLAGS=-m
> dt_binding_check'
> on your patch (DT_CHECKER_FLAGS is new in v5.13):
>
> yamllint warnings/errors:
>
> dtschema/dtc warnings/errors:
> /builds/robherring/linux-dt-
> review/Documentation/devicetree/bindings/display/mediatek/mediatek,md
> p-rdma.yaml: properties:compatible: [{'const': 'mediatek,mt8195-vdo1-
> rdma'}] is not of type 'object', 'boolean'
> from schema $id:
> https://urldefense.com/v3/__http://json-schema.org/draft-07/schema*__;Iw!!CTRNKA9wMg0ARbw!3hhZrSKSWnCN5Bha9laiHlB5JCx9_p-ksaYDZmoCLQRi1tI4KJCcTJQva2vds3j3bwKF$
>
> /builds/robherring/linux-dt-
> review/Documentation/devicetree/bindings/display/mediatek/mediatek,md
> p-rdma.yaml: ignoring, error in schema: properties: compatible
> Documentation/devicetree/bindings/display/mediatek/mediatek,mdp-
> rdma.example.dtb:0:0: /example-0/soc/rdma@1c104000: failed to match
> any schema with compatible: ['mediatek,mt8195-vdo1-rdma']
>
> doc reference errors (make refcheckdocs):
>
> See https://patchwork.ozlabs.org/patch/
>
> This check can fail if there are any dependencies. The base for a
> patch
> series is generally the most recent rc1.
>
> If you already ran 'make dt_binding_check' and didn't see the above
> error(s), then make sure 'yamllint' is installed and dt-schema is up
> to
> date:
>
> pip3 install dtschema --upgrade
>
> Please check and re-submit.
>

Hello Rob,

We found that if we write this, and the error will disapear:
properties:
compatible:
- - const: mediatek,mt8195-vdo1-rdma
+ items:
+ - const: mediatek,mt8195-vdo1-rdma

But from Krzysztof's review[1], he adviced us to drop items.

Is there any suggsetion for this error or do we have any
misunderstanding?

[1]:https://patchwork.kernel.org/comment/24849447/

BRs,
Rex

\
 
 \ /
  Last update: 2022-06-06 15:34    [W:0.099 / U:0.128 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site