lkml.org 
[lkml]   [2022]   [Jun]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH] Documentation: kunit: eliminate code-block warnings
From
Hi Mauro,

On 6/28/22 00:17, Mauro Carvalho Chehab wrote:
> Em Sat, 25 Jun 2022 08:12:00 -0700
> Randy Dunlap <rdunlap@infradead.org> escreveu:
>
>>> So which version of Sphinx are you using? The language argument became
>>> optional in 2.0, so you'd need to be running something pretty ancient to
>>> see this.
>>>
>>> Ah, I see 1.8.5 in your later message...how wedded are you to that
>>> version?
>>
>> It's what ships with OpenSuse Leap 15.3, which I have been using for quite
>> a long time.
>>
>> I see that there is now OpenSuse Leap 15.4, so I could upgrade to that,
>> but I don't know what version on Sphinx it uses.
>
> It seems that there are two versions on it, packaged with different
> names:
>
> 2.3.1:
> https://download.opensuse.org/distribution/leap/15.4/repo/oss/noarch/python3-Sphinx-2.3.1-150400.1.7.noarch.rpm
> 4.2.0:
> https://download.opensuse.org/distribution/leap/15.4/repo/oss/noarch/python3-Sphinx_4_2_0-4.2.0-150400.11.6.noarch.rpm
>
> It should be noticed that, while we don't decide to remove support for
> Sphinx < 3, kernel-doc has two different outputs, depending on Sphinx C
> domain support. The legacy support is enabled with version < 3 [1].
>
> As we're currently discussing dropping support for Sphinx version < 3,
> I would recommend you to use the 4.2 package.
>
> Regards,
> Mauro
>
> [1] Version 3.0 is a bad choice, as the C domain is partially broken.

Thanks for the info. I'll take care of it.

--
~Randy

\
 
 \ /
  Last update: 2022-06-28 16:22    [W:0.045 / U:0.256 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site