lkml.org 
[lkml]   [2022]   [May]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v9 2/9] PCI: Replace magic constant for PCI Sig Vendor ID
On Tue, 31 May 2022, ira.weiny@intel.com wrote:

>From: Ira Weiny <ira.weiny@intel.com>
>
>Replace the magic value in pci_bus_crs_vendor_id() with
>PCI_VENDOR_ID_PCI_SIG.
>
>Reviewed-by: Dan Williams <dan.j.williams@intel.com>
>Suggested-by: Bjorn Helgaas <bhelgaas@google.com>
>Acked-by: Bjorn Helgaas <bhelgaas@google.com>
>Signed-off-by: Ira Weiny <ira.weiny@intel.com>

Reviewed-by: Davidlohr Bueso <dave@stgolabs.net>

>---
>Changes from V6
> Simplify commit message
>---
> drivers/pci/probe.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
>diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
>index 17a969942d37..6280e780a48c 100644
>--- a/drivers/pci/probe.c
>+++ b/drivers/pci/probe.c
>@@ -2312,7 +2312,7 @@ EXPORT_SYMBOL(pci_alloc_dev);
>
> static bool pci_bus_crs_vendor_id(u32 l)
> {
>- return (l & 0xffff) == 0x0001;
>+ return (l & 0xffff) == PCI_VENDOR_ID_PCI_SIG;
> }
>
> static bool pci_bus_wait_crs(struct pci_bus *bus, int devfn, u32 *l,
>
>--
>2.35.1
>

\
 
 \ /
  Last update: 2022-05-31 19:02    [W:0.199 / U:0.164 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site