lkml.org 
[lkml]   [2022]   [May]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 04/11] mm: vmscan: rework move_pages_to_lru()
On Tue, May 24, 2022 at 03:38:50PM -0400, Johannes Weiner wrote:
> On Tue, May 24, 2022 at 02:05:44PM +0800, Muchun Song wrote:
> > In the later patch, we will reparent the LRU pages. The pages moved to
> > appropriate LRU list can be reparented during the process of the
> > move_pages_to_lru(). So holding a lruvec lock by the caller is wrong, we
> > should use the more general interface of folio_lruvec_relock_irq() to
> > acquire the correct lruvec lock.
> >
> > Signed-off-by: Muchun Song <songmuchun@bytedance.com>
> > ---
> > mm/vmscan.c | 49 +++++++++++++++++++++++++------------------------
> > 1 file changed, 25 insertions(+), 24 deletions(-)
> >
> > diff --git a/mm/vmscan.c b/mm/vmscan.c
> > index 1678802e03e7..761d5e0dd78d 100644
> > --- a/mm/vmscan.c
> > +++ b/mm/vmscan.c
> > @@ -2230,23 +2230,28 @@ static int too_many_isolated(struct pglist_data *pgdat, int file,
> > * move_pages_to_lru() moves pages from private @list to appropriate LRU list.
> > * On return, @list is reused as a list of pages to be freed by the caller.
> > *
> > - * Returns the number of pages moved to the given lruvec.
> > + * Returns the number of pages moved to the appropriate LRU list.
> > + *
> > + * Note: The caller must not hold any lruvec lock.
> > */
> > -static unsigned int move_pages_to_lru(struct lruvec *lruvec,
> > - struct list_head *list)
> > +static unsigned int move_pages_to_lru(struct list_head *list)
> > {
> > - int nr_pages, nr_moved = 0;
> > + int nr_moved = 0;
> > + struct lruvec *lruvec = NULL;
> > LIST_HEAD(pages_to_free);
> > - struct page *page;
> >
> > while (!list_empty(list)) {
> > - page = lru_to_page(list);
> > + int nr_pages;
> > + struct folio *folio = lru_to_folio(list);
> > + struct page *page = &folio->page;
> > +
> > + lruvec = folio_lruvec_relock_irq(folio, lruvec);
> > VM_BUG_ON_PAGE(PageLRU(page), page);
> > list_del(&page->lru);
> > if (unlikely(!page_evictable(page))) {
> > - spin_unlock_irq(&lruvec->lru_lock);
> > + unlock_page_lruvec_irq(lruvec);
>
> Better to stick with the opencoded unlock. It matches a bit better
> with the locking function, compared to locking folio and unlocking
> page...
>

Seems like we are missing folio unlock variants.
How about intriducing folio_lruvec_unlock() variants?
There are a lot of places where locking folio and
unlocking page.

Thanks.

> Aside from that, this looks good:
>
> Acked-by: Johannes Weiner <hannes@cmpxchg.org>
>

Thanks.


\
 
 \ /
  Last update: 2022-05-25 13:39    [W:0.277 / U:0.424 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site