lkml.org 
[lkml]   [2022]   [May]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] sysctl: Merge adjacent CONFIG_TREE_RCU blocks
On Tue, May 17, 2022 at 05:07:31PM +0200, Geert Uytterhoeven wrote:
> There are two adjacent sysctl entries protected by the same
> CONFIG_TREE_RCU config symbol. Merge them into a single block to
> improve readability.
>
> Use the more common "#ifdef" form while at it.
>
> Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>

If you would like me to take this, please let me know. (The default
would be not the upcoming merge window, but the one after that.)

If you would rather send it via some other path:

Reviewed-by: Paul E. McKenney <paulmck@kernel.org>

> ---
> kernel/sysctl.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/kernel/sysctl.c b/kernel/sysctl.c
> index 82bcf5e3009fa377..597069da18148f42 100644
> --- a/kernel/sysctl.c
> +++ b/kernel/sysctl.c
> @@ -2227,7 +2227,7 @@ static struct ctl_table kern_table[] = {
> .extra1 = SYSCTL_ZERO,
> .extra2 = SYSCTL_ONE,
> },
> -#if defined(CONFIG_TREE_RCU)
> +#ifdef CONFIG_TREE_RCU
> {
> .procname = "panic_on_rcu_stall",
> .data = &sysctl_panic_on_rcu_stall,
> @@ -2237,8 +2237,6 @@ static struct ctl_table kern_table[] = {
> .extra1 = SYSCTL_ZERO,
> .extra2 = SYSCTL_ONE,
> },
> -#endif
> -#if defined(CONFIG_TREE_RCU)
> {
> .procname = "max_rcu_stall_to_panic",
> .data = &sysctl_max_rcu_stall_to_panic,
> --
> 2.25.1
>

\
 
 \ /
  Last update: 2022-05-17 17:58    [W:7.127 / U:0.036 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site