lkml.org 
[lkml]   [2022]   [May]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v3 3/5] soc: mediatek: pwrap: Move and check return value of platform_get_irq()
From


On 16/05/2022 14:46, AngeloGioacchino Del Regno wrote:
> Move the call to platform_get_irq() earlier in the probe function
> and check for its return value: if no interrupt is specified, it
> wouldn't make sense to try to call devm_request_irq() so, in that
> case, we can simply return early.
>
> Moving the platform_get_irq() call also makes it possible to use
> one less goto, as clocks aren't required at that stage.
>
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
> Reviewed-by: Nícolas F. R. A. Prado <nfraprado@collabora.com>
> Tested-by: Nícolas F. R. A. Prado <nfraprado@collabora.com>
> ---
> drivers/soc/mediatek/mtk-pmic-wrap.c | 5 ++++-
> 1 file changed, 4 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/soc/mediatek/mtk-pmic-wrap.c b/drivers/soc/mediatek/mtk-pmic-wrap.c
> index 852514366f1f..332cbcabc299 100644
> --- a/drivers/soc/mediatek/mtk-pmic-wrap.c
> +++ b/drivers/soc/mediatek/mtk-pmic-wrap.c
> @@ -2204,6 +2204,10 @@ static int pwrap_probe(struct platform_device *pdev)
> if (!wrp)
> return -ENOMEM;
>
> + irq = platform_get_irq(pdev, 0);
> + if (irq < 0)
> + return irq;
> +
> platform_set_drvdata(pdev, wrp);
>
> wrp->master = of_device_get_match_data(&pdev->dev);
> @@ -2316,7 +2320,6 @@ static int pwrap_probe(struct platform_device *pdev)
> if (HAS_CAP(wrp->master->caps, PWRAP_CAP_INT1_EN))
> pwrap_writel(wrp, wrp->master->int1_en_all, PWRAP_INT1_EN);
>
> - irq = platform_get_irq(pdev, 0);

For better readability of the code I'd prefer to keep platform_get_irq next to
devm_request_irq. I understand that you did this change so that you don't have
to code
if (irq < 0) {
ret = irq;
goto err_out2;
}

Or do I miss something?

Regards,
Matthias

> ret = devm_request_irq(wrp->dev, irq, pwrap_interrupt,
> IRQF_TRIGGER_HIGH,
> "mt-pmic-pwrap", wrp);

\
 
 \ /
  Last update: 2022-05-17 11:20    [W:0.094 / U:0.388 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site