lkml.org 
[lkml]   [2022]   [Apr]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH 5.16 0691/1017] NFS: remove unneeded check in decode_devicenotify_args()
    Date
    From: Alexey Khoroshilov <khoroshilov@ispras.ru>

    [ Upstream commit cb8fac6d2727f79f211e745b16c9abbf4d8be652 ]

    [You don't often get email from khoroshilov@ispras.ru. Learn why this is important at http://aka.ms/LearnAboutSenderIdentification.]

    Overflow check in not needed anymore after we switch to kmalloc_array().

    Signed-off-by: Alexey Khoroshilov <khoroshilov@ispras.ru>
    Fixes: a4f743a6bb20 ("NFSv4.1: Convert open-coded array allocation calls to kmalloc_array()")
    Signed-off-by: Trond Myklebust <trond.myklebust@hammerspace.com>
    Signed-off-by: Sasha Levin <sashal@kernel.org>
    ---
    fs/nfs/callback_xdr.c | 4 ----
    1 file changed, 4 deletions(-)

    diff --git a/fs/nfs/callback_xdr.c b/fs/nfs/callback_xdr.c
    index f90de8043b0f..8dcb08e1a885 100644
    --- a/fs/nfs/callback_xdr.c
    +++ b/fs/nfs/callback_xdr.c
    @@ -271,10 +271,6 @@ __be32 decode_devicenotify_args(struct svc_rqst *rqstp,
    n = ntohl(*p++);
    if (n == 0)
    goto out;
    - if (n > ULONG_MAX / sizeof(*args->devs)) {
    - status = htonl(NFS4ERR_BADXDR);
    - goto out;
    - }

    args->devs = kmalloc_array(n, sizeof(*args->devs), GFP_KERNEL);
    if (!args->devs) {
    --
    2.34.1


    \
     
     \ /
      Last update: 2022-04-05 15:39    [W:4.095 / U:0.008 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site