lkml.org 
[lkml]   [2022]   [Apr]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 1/2] drm/amdkfd: Use bitmap_zalloc() when applicable
From
Hi Christophe,

I just stumbled over this patch series while cleaning up my inbox. Sorry
for dropping it back in November. I'm about to apply it but I noticed
that patch 1 is missing a Signed-off-by. Is it OK to add that in your name?

Thanks,
  Felix


Am 2021-11-28 um 11:45 schrieb Christophe JAILLET:
> 'kfd->gtt_sa_bitmap' is a bitmap. So use 'bitmap_zalloc()' to simplify
> code, improve the semantic and avoid some open-coded arithmetic in
> allocator arguments.
>
> Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
> consistency.
> ---
> drivers/gpu/drm/amd/amdkfd/kfd_device.c | 12 +++---------
> 1 file changed, 3 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_device.c b/drivers/gpu/drm/amd/amdkfd/kfd_device.c
> index e1294fba0c26..c5a0ce44a295 100644
> --- a/drivers/gpu/drm/amd/amdkfd/kfd_device.c
> +++ b/drivers/gpu/drm/amd/amdkfd/kfd_device.c
> @@ -1252,8 +1252,6 @@ int kgd2kfd_schedule_evict_and_restore_process(struct mm_struct *mm,
> static int kfd_gtt_sa_init(struct kfd_dev *kfd, unsigned int buf_size,
> unsigned int chunk_size)
> {
> - unsigned int num_of_longs;
> -
> if (WARN_ON(buf_size < chunk_size))
> return -EINVAL;
> if (WARN_ON(buf_size == 0))
> @@ -1264,11 +1262,8 @@ static int kfd_gtt_sa_init(struct kfd_dev *kfd, unsigned int buf_size,
> kfd->gtt_sa_chunk_size = chunk_size;
> kfd->gtt_sa_num_of_chunks = buf_size / chunk_size;
>
> - num_of_longs = (kfd->gtt_sa_num_of_chunks + BITS_PER_LONG - 1) /
> - BITS_PER_LONG;
> -
> - kfd->gtt_sa_bitmap = kcalloc(num_of_longs, sizeof(long), GFP_KERNEL);
> -
> + kfd->gtt_sa_bitmap = bitmap_zalloc(kfd->gtt_sa_num_of_chunks,
> + GFP_KERNEL);
> if (!kfd->gtt_sa_bitmap)
> return -ENOMEM;
>
> @@ -1278,13 +1273,12 @@ static int kfd_gtt_sa_init(struct kfd_dev *kfd, unsigned int buf_size,
> mutex_init(&kfd->gtt_sa_lock);
>
> return 0;
> -
> }
>
> static void kfd_gtt_sa_fini(struct kfd_dev *kfd)
> {
> mutex_destroy(&kfd->gtt_sa_lock);
> - kfree(kfd->gtt_sa_bitmap);
> + bitmap_free(kfd->gtt_sa_bitmap);
> }
>
> static inline uint64_t kfd_gtt_sa_calc_gpu_addr(uint64_t start_addr,

\
 
 \ /
  Last update: 2022-04-26 20:03    [W:0.071 / U:0.220 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site