lkml.org 
[lkml]   [2022]   [Mar]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[RFC PATCH 00/15] treewide: rename fsleep
Date
Hi,

I recently stumbled over the relatively new function fsleep(). While I
think it is usful, I also think the name is too short to be
self-explanatory. This is why I suggest a rename before it gets even
wider use in the kernel, see patch 1. As you can see from the
statistics below, the churn is still in the acceptable range IMO.

The name 'usleep_autoyield' is the best I could come up with, but if you
can think of something better I am all ears. This is why the series is
still RFC and not sent to subsystem mailing lists. The base is v5.17-rc8
but my plan is to resend it after 5.18-rc1 with all new fsleep-users
fixed as well. And remove the fallback late in the 5.18 cycle. If we can
agree on something that is.

buildbot is happy with the changes. A branch can be found here:

git://git.kernel.org/pub/scm/linux/kernel/git/wsa/linux.git renesas/usleep_autoyield

Please let me know what you think!

All the best,

Wolfram


Wolfram Sang (15):
delay: rename fsleep to usleep_autoyield
base: regmap: use new name 'usleep_autoyield' instead of 'fsleep'
bus: mhi: core: use new name 'usleep_autoyield' instead of 'fsleep'
iio: adc: use new name 'usleep_autoyield' instead of 'fsleep'
memory: tegra: use new name 'usleep_autoyield' instead of 'fsleep'
mfd: use new name 'usleep_autoyield' instead of 'fsleep'
mux: use new name 'usleep_autoyield' instead of 'fsleep'
net: ethernet: realtek: use new name 'usleep_autoyield' instead of
'fsleep'
net: mdio: use new name 'usleep_autoyield' instead of 'fsleep'
net: phy: use new name 'usleep_autoyield' instead of 'fsleep'
net: wireless: realtek: rtw88: use new name 'usleep_autoyield' instead
of 'fsleep'
net: wireless: realtek: rtw89: use new name 'usleep_autoyield' instead
of 'fsleep'
thermal: tegra: use new name 'usleep_autoyield' instead of 'fsleep'
usb: chipidea: use new name 'usleep_autoyield' instead of 'fsleep'
delay: remove the fallback for fsleep

Documentation/timers/timers-howto.rst | 2 +-
drivers/base/regmap/regmap.c | 4 ++--
drivers/bus/mhi/core/main.c | 2 +-
drivers/iio/adc/ti-tsc2046.c | 2 +-
drivers/memory/tegra/tegra20.c | 2 +-
drivers/mfd/acer-ec-a500.c | 2 +-
drivers/mux/core.c | 2 +-
drivers/net/ethernet/realtek/r8169_main.c | 8 ++++----
drivers/net/mdio/mdio-ipq4019.c | 2 +-
drivers/net/phy/broadcom.c | 2 +-
drivers/net/phy/mdio_bus.c | 4 ++--
drivers/net/phy/mdio_device.c | 2 +-
drivers/net/wireless/realtek/rtw88/rtw8822c.c | 8 ++++----
drivers/net/wireless/realtek/rtw89/fw.c | 2 +-
drivers/net/wireless/realtek/rtw89/mac.c | 6 +++---
drivers/net/wireless/realtek/rtw89/pci.c | 2 +-
drivers/net/wireless/realtek/rtw89/rtw8852a.c | 4 ++--
drivers/net/wireless/realtek/rtw89/rtw8852a_rfk.c | 8 ++++----
drivers/thermal/tegra/tegra30-tsensor.c | 2 +-
drivers/usb/chipidea/ci_hdrc_tegra.c | 6 +++---
include/linux/delay.h | 2 +-
21 files changed, 37 insertions(+), 37 deletions(-)

--
2.34.1

\
 
 \ /
  Last update: 2022-03-21 17:13    [W:0.050 / U:0.060 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site