lkml.org 
[lkml]   [2022]   [Feb]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/3] rtc,x86: RTC CMOS refactoring
Date
Hello,

The main aim of this series is to remove duplicated code in
mach_get_cmos_time() in arch/x86/kernel/rtc.c . This function performed
the same thing as mc146818_get_time() - reading the time from the CMOS
RTC - but used a different algorithm. So modify it to use standard
mc146818_get_time().

First, to make these functions more similar to each other (and also for
another reason described in the patch), reduce the polling period in
mc146818_get_time(). Then, rewrite mach_get_cmos_time().

The last patch renames a function in arch/x86/kernel/rtc.c.

I have tested this on three different computers.

Greetings,
Mateusz

Signed-off-by: Mateusz Jończyk <mat.jonczyk@o2.pl>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Ingo Molnar <mingo@redhat.com>
Cc: Borislav Petkov <bp@alien8.de>
Cc: Dave Hansen <dave.hansen@linux.intel.com>
Cc: x86@kernel.org
Cc: "H. Peter Anvin" <hpa@zytor.com>
Cc: Alessandro Zummo <a.zummo@towertech.it>
Cc: Alexandre Belloni <alexandre.belloni@bootlin.com>

Mateusz Jończyk (3):
rtc-mc146818-lib: reduce RTC_UIP polling period
x86/rtc: rewrite mach_get_cmos_time
x86/rtc: rename mach_set_rtc_mmss

arch/x86/include/asm/mc146818rtc.h | 2 +-
arch/x86/kernel/rtc.c | 63 +++++-------------------------
arch/x86/kernel/x86_init.c | 2 +-
drivers/rtc/rtc-mc146818-lib.c | 8 ++--
4 files changed, 15 insertions(+), 60 deletions(-)


base-commit: cfb92440ee71adcc2105b0890bb01ac3cddb8507
--
2.25.1

\
 
 \ /
  Last update: 2022-02-25 22:51    [W:0.048 / U:1.696 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site