lkml.org 
[lkml]   [2022]   [Dec]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v4 28/32] KVM: SVM: Require logical ID to be power-of-2 for AVIC entry
From
Date
On Fri, 2022-12-09 at 00:00 +0200, Maxim Levitsky wrote:
> On Sat, 2022-10-01 at 00:59 +0000, Sean Christopherson wrote:
> > Do not modify AVIC's logical ID table if the logical ID portion of the
> > LDR is not a power-of-2, i.e. if the LDR has multiple bits set. Taking
> > only the first bit means that KVM will fail to match MDAs that intersect
> > with "higher" bits in the "ID"
> >
> > The "ID" acts as a bitmap, but is referred to as an ID because theres an
> > implicit, unenforced "requirement" that software only set one bit. This
> > edge case is arguably out-of-spec behavior, but KVM cleanly handles it
> > in all other cases, e.g. the optimized logical map (and AVIC!) is also
> > disabled in this scenario.
> >
> > Refactor the code to consolidate the checks, and so that the code looks
> > more like avic_kick_target_vcpus_fast().
> >
> > Fixes: 18f40c53e10f ("svm: Add VMEXIT handlers for AVIC")
> > Cc: Suravee Suthikulpanit <suravee.suthikulpanit@amd.com>
> > Cc: Maxim Levitsky <mlevitsk@redhat.com>
> > Signed-off-by: Sean Christopherson <seanjc@google.com>
> > ---
> > arch/x86/kvm/svm/avic.c | 30 +++++++++++++++---------------
> > 1 file changed, 15 insertions(+), 15 deletions(-)
> >
> > diff --git a/arch/x86/kvm/svm/avic.c b/arch/x86/kvm/svm/avic.c
> > index 4b6fc9d64f4d..a9e4e09f83fc 100644
> > --- a/arch/x86/kvm/svm/avic.c
> > +++ b/arch/x86/kvm/svm/avic.c
> > @@ -513,26 +513,26 @@ unsigned long avic_vcpu_get_apicv_inhibit_reasons(struct kvm_vcpu *vcpu)
> > static u32 *avic_get_logical_id_entry(struct kvm_vcpu *vcpu, u32 ldr, bool flat)
> > {
> > struct kvm_svm *kvm_svm = to_kvm_svm(vcpu->kvm);
> > - int index;
> > u32 *logical_apic_id_table;
> > - int dlid = GET_APIC_LOGICAL_ID(ldr);
> > + u32 cluster, index;
> >
> > - if (!dlid)
> > - return NULL;
> > + ldr = GET_APIC_LOGICAL_ID(ldr);
> >
> > - if (flat) { /* flat */
> > - index = ffs(dlid) - 1;
> > - if (index > 7)
> > + if (flat) {
> > + cluster = 0;
> > + } else {
> > + cluster = (ldr >> 4) << 2;
> > + if (cluster >= 0xf)
> > return NULL;
> > - } else { /* cluster */
> > - int cluster = (dlid & 0xf0) >> 4;
> > - int apic = ffs(dlid & 0x0f) - 1;
> > -
> > - if ((apic < 0) || (apic > 7) ||
> > - (cluster >= 0xf))
> > - return NULL;
> > - index = (cluster << 2) + apic;
> > + ldr &= 0xf;
> > }
> > + if (!ldr || !is_power_of_2(ldr))
> > + return NULL;
> > +
> > + index = __ffs(ldr);
> > + if (WARN_ON_ONCE(index > 7))
> > + return NULL;
> > + index += (cluster << 2);
> >
> > logical_apic_id_table = (u32 *) page_address(kvm_svm->avic_logical_id_table_page);
> >
>
> Looks good.

I hate to say it but this patch has a bug:

We have both 'cluster = (ldr >> 4) << 2' and then 'index += (cluster << 2)'

One of the shifts has to go.

Best regards,
Maxim Levitsky


>
> For future refactoring, I also suggest to rename this function to 'avic_get_logical_id_table_entry'
> to stress the fact that it gets a pointer to the AVIC's data structure.
>
> Same for 'avic_get_physical_id_entry'
>
> And also while at it : the 'svm->avic_physical_id_cache', is a very misleading name,
>
> It should be svm->avic_physical_id_table_entry_ptr with a comment explaining that
> is is the pointer to physid table entry.
>
>
> Reviewed-by: Maxim Levitsky <mlevitsk@redhat.com>
>
>
>
> Best regards,
> Maxim Levitsky


\
 
 \ /
  Last update: 2023-03-26 23:22    [W:0.084 / U:0.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site