lkml.org 
[lkml]   [2022]   [Dec]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v3 03/10] KEYS: X.509: Parse Basic Constraints for CA
From
Date
> diff --git a/crypto/asymmetric_keys/x509_parser.h b/crypto/asymmetric_keys/x509_parser.h
> index a299c9c56f40..7c5c0ad1c22e 100644
> --- a/crypto/asymmetric_keys/x509_parser.h
> +++ b/crypto/asymmetric_keys/x509_parser.h
> @@ -38,6 +38,7 @@ struct x509_certificate {
> bool self_signed; /* T if self-signed (check unsupported_sig too) */
> bool unsupported_sig; /* T if signature uses unsupported crypto */
> bool blacklisted;
> + bool root_ca; /* T if basic constraints CA is set */
> };

The variable "root_ca" should probably be renamed to just "ca", right?

--

thanks,

Mimi

\
 
 \ /
  Last update: 2022-12-15 12:11    [W:0.193 / U:0.644 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site