lkml.org 
[lkml]   [2022]   [Nov]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v4 08/13] tty: serial: qcom-geni-serial: refactor qcom_geni_serial_handle_tx()
From
On 29. 11. 22, 12:00, Bartosz Golaszewski wrote:
> From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
>
> qcom_geni_serial_handle_tx() is pretty big, let's move the code that
> handles the actual writing of data to a separate function which makes
> sense in preparation for introducing a dma variant of handle_tx().

I think you should split this patch into two. One to extract the code
^^^. And one to clean it up:

> Let's also shuffle the code a bit, drop unneeded variables and use
> uart_xmit_advance() instead of handling tail->xmit manually.

As it is, it's hard to follow what is being changed.


...
> @@ -704,19 +704,41 @@ static void qcom_geni_serial_start_rx(struct uart_port *uport)
> writel(irq_en, uport->membase + SE_GENI_M_IRQ_EN);
> }
>
> +static void qcom_geni_serial_send_chunk_fifo(struct uart_port *uport,
> + unsigned int chunk)
> +{
> + struct qcom_geni_serial_port *port = to_dev_port(uport);
> + struct circ_buf *xmit = &uport->state->xmit;
> + unsigned int tx_bytes, remaining = chunk;
> + u8 buf[BYTES_PER_FIFO_WORD];
> + int c;

c can/should be uint too.

> +
> + while (remaining) {
> + memset(buf, 0, sizeof(buf));
> + tx_bytes = min(remaining, BYTES_PER_FIFO_WORD);
> +
> + for (c = 0; c < tx_bytes ; c++) {
> + buf[c] = xmit->buf[xmit->tail];
> + uart_xmit_advance(uport, 1);
> + }
> +
> + iowrite32_rep(uport->membase + SE_GENI_TX_FIFOn, buf, 1);
> +
> + remaining -= tx_bytes;
> + port->tx_remaining -= tx_bytes;
> + }
> +}

thanks,
--
--
js
suse labs

\
 
 \ /
  Last update: 2022-11-30 10:40    [W:0.057 / U:0.508 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site