lkml.org 
[lkml]   [2022]   [Nov]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v2] media: mediatek: vcodec: fix h264 cavlc bitstream fail
From
Il 18/10/22 13:41, Yunfei Dong ha scritto:
> Some cavlc bistream will decode fail when the frame size is small than

s/small/smaller/g

> 20 bytes. Need to add pending data at the end of the bitstream.
>
> For the minimum size of mapped memory is 256 bytes(16x16), adding four bytes data
> won't lead to access unknown virtual memory.
>
> Fixes: 59fba9eed5a7 ("media: mediatek: vcodec: support stateless H.264 decoding for mt8192")
> Signed-off-by: Yunfei Dong <yunfei.dong@mediatek.com>
> ---
> compared with v1:
> - add detail comments for function: vdec_h264_insert_startcode.
> - re-write commit message.
> ---
> .../vcodec/vdec/vdec_h264_req_multi_if.c | 32 +++++++++++++++++--
> 1 file changed, 29 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/media/platform/mediatek/vcodec/vdec/vdec_h264_req_multi_if.c b/drivers/media/platform/mediatek/vcodec/vdec/vdec_h264_req_multi_if.c
> index 4cc92700692b..18e048755d11 100644
> --- a/drivers/media/platform/mediatek/vcodec/vdec/vdec_h264_req_multi_if.c
> +++ b/drivers/media/platform/mediatek/vcodec/vdec/vdec_h264_req_multi_if.c
> @@ -539,6 +539,29 @@ static int vdec_h264_slice_core_decode(struct vdec_lat_buf *lat_buf)
> return 0;
> }
>
> +static void vdec_h264_insert_startcode(struct mtk_vcodec_dev *vcodec_dev, unsigned char *buf,
> + size_t *bs_size, struct mtk_h264_pps_param *pps)
> +{
> + struct device *dev = &vcodec_dev->plat_dev->dev;
> +
> + /* Need to add pending data at the end of bitstream when bs_sz is small than
> + * 20 bytes for cavlc bitstream, or lat will decode fail. This pending data is
> + * useful for mt8192 and mt8195 platform.

What is the reason why other SoCs don't need this?

> + *
> + * cavlc bitstream when entropy_coding_mode_flag is false.
> + */
> + if (pps->entropy_coding_mode_flag || *bs_size > 20 ||
> + !(of_device_is_compatible(dev->of_node, "mediatek,mt8192-vcodec-dec") ||
> + of_device_is_compatible(dev->of_node, "mediatek,mt8195-vcodec-dec")))

I'm not comfortable seeing of_device_is_compatible... this list will grow whenever
a new SoC needing this appears.
Please think about a good name for a flag/quirk, or a bool, in the platform data
for these two SoCs and use it.

Regards,
Angelo

\
 
 \ /
  Last update: 2022-11-14 12:13    [W:0.073 / U:0.732 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site