lkml.org 
[lkml]   [2022]   [Oct]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH linux-next] null_blk: use sysfs_emit() to instead of scnprintf()
From
On 10/21/22 17:54, yexingchen116@gmail.com wrote:
> From: ye xingchen <ye.xingchen@zte.com.cn>
>
> Replace the open-code with sysfs_emit() to simplify the code.
>
> Signed-off-by: ye xingchen <ye.xingchen@zte.com.cn>

Reviewed-by: Damien Le Moal <damien.lemoal@opensource.wdc.com>

> ---
> drivers/block/null_blk/main.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/block/null_blk/main.c b/drivers/block/null_blk/main.c
> index 1f154f92f4c2..5317ef2ba227 100644
> --- a/drivers/block/null_blk/main.c
> +++ b/drivers/block/null_blk/main.c
> @@ -255,18 +255,18 @@ static inline struct nullb_device *to_nullb_device(struct config_item *item)
>
> static inline ssize_t nullb_device_uint_attr_show(unsigned int val, char *page)
> {
> - return snprintf(page, PAGE_SIZE, "%u\n", val);
> + return sysfs_emit(page, "%u\n", val);
> }
>
> static inline ssize_t nullb_device_ulong_attr_show(unsigned long val,
> char *page)
> {
> - return snprintf(page, PAGE_SIZE, "%lu\n", val);
> + return sysfs_emit(page, "%lu\n", val);
> }
>
> static inline ssize_t nullb_device_bool_attr_show(bool val, char *page)
> {
> - return snprintf(page, PAGE_SIZE, "%u\n", val);
> + return sysfs_emit(page, "%u\n", val);
> }
>
> static ssize_t nullb_device_uint_attr_store(unsigned int *val,

--
Damien Le Moal
Western Digital Research

\
 
 \ /
  Last update: 2022-10-21 11:45    [W:0.065 / U:0.088 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site