lkml.org 
[lkml]   [2022]   [Jan]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH -next] ieee802154: atusb: move to new USB API
From

Hello.

On 05.01.22 15:49, Pavel Skripkin wrote:
> @@ -176,9 +105,13 @@ static int atusb_read_subreg(struct atusb *lp,
> unsigned int addr, unsigned int mask,
> unsigned int shift)
> {
> - int rc;
> + int rc, ret;
> +
> + ret = usb_control_msg_recv(lp->usb_dev, 0, ATUSB_REG_READ, ATUSB_REQ_FROM_DEV,

You are changing the meaning of the rc variable away from a return code.
Its the register value now. I would prefer if we change the name to
something like reg to reflect this new meaning.

> + 0, addr, &rc, 1, 1000, GFP_KERNEL);
> + if (ret < 0)
> + return ret;
>
> - rc = atusb_read_reg(lp, addr);
> rc = (rc & mask) >> shift;
>
> return rc;

The change above and the bug fix I reported the other day is all that is
missing for this to be applied. You want to send a v2 with this changes
or do you prefer me doing them here locally and apply?

regards
Stefan Schmidt

\
 
 \ /
  Last update: 2022-01-07 14:47    [W:0.140 / U:0.852 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site