lkml.org 
[lkml]   [2021]   [Sep]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v3 3/3] staging: r8188eu: Shorten calls chain of rtw_write8/16/32/N()
Date
On Thursday, September 9, 2021 10:21:04 AM CEST David Laight wrote:
> From: Fabio M. De Francesco
> > To: Larry Finger <Larry.Finger@lwfinger.net>; Phillip Potter
<phil@philpotter.co.uk>; Greg Kroah-
> > > ...
> > > > diff --git a/drivers/staging/r8188eu/hal/usb_ops_linux.c b/drivers/
> > staging/r8188eu/hal/usb_ops_linux.c
> > > > index f9c4fd5a2c53..e31d1b1fdb12 100644
> > > > --- a/drivers/staging/r8188eu/hal/usb_ops_linux.c
> > > > +++ b/drivers/staging/r8188eu/hal/usb_ops_linux.c
> > > > @@ -8,76 +8,51 @@
> > > > #include "../include/recv_osdep.h"
> > > > #include "../include/rtl8188e_hal.h"
> > > >
> > > > -static int usbctrl_vendorreq(struct intf_hdl *pintfhdl, u16 value,
void
> > *pdata, u16 len, u8
> > > > requesttype)
> > > > +static int usb_read(struct intf_hdl *intfhdl, u32 addr, void *data,
u8
> > size)
> > > > {
> > > > - struct adapter *adapt = pintfhdl->padapter;
> > > > - struct dvobj_priv *dvobjpriv = adapter_to_dvobj(adapt);
> > > > + u16 value = (u16)(addr & 0x0000ffff);
> > > > + struct adapter *adapt = intfhdl->padapter;
> > > > + struct dvobj_priv *dvobjpriv = adapter_to_dvobj(adapt);
> > > > struct usb_device *udev = dvobjpriv->pusbdev;
> > > > - unsigned int pipe;
> > > > - int status = 0;
> > > > - u8 *pIo_buf;
> > > > + int status;
> > > > + u8 *io_buf;
> > >
> > > Some of these changes are whitespace or renames.
> > > They ought to be in a different patch.
> >
> > Dear David,
> >
> > No, they are not.
> >
> > I guess you were misled by the structure of the patches. There is nothing
I
> > can do about it. Please notice that usb_read() is created in 2/3, and I'm
> > free to use the name of the variables I like in new functions.
Furthermore,
> > usb_read() is untouched in 3/3. I can see why you thought they are
renames :)
>
> Hmmm... it might be worth playing with the patches and the
> order of functions so that the diffs are meaningful.

Yes, I agree. Readability of the diffs should be taken into account because
it make the work of reviewers a bit easier.

I'm trying and see if some clean-up of usbctrl_vendorreq() (from which I
copied most of the code and pasted in my new functions) can improve patches
readability if it is carried out preventively (I mean before creating
usb_read() in 2/3 and usb_write() in 3/3).

I hope that that preventive clean-ups would help when in 3/3 I will delete
usbctrl_vendorreq() and the new code overlaps the lines that were used by
that function.

Let's see... Perhaps it may solve out problem :)

Thanks,

Fabio

>
> Some experimentation can be needed.
>
> David
>
> -
> Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1
1PT, UK
> Registration No: 1397386 (Wales)
>




\
 
 \ /
  Last update: 2021-09-09 10:32    [W:0.050 / U:1.364 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site